Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Table Rendering problem in Windows 7(SWT Table has unfilled spaces between columns in Windows 7)
Table Rendering problem in Windows 7 [message #709676] Thu, 04 August 2011 03:10
rfang is currently offline rfang
Messages: 1
Registered: August 2011
Junior Member
Hi guys,

We're having some issues migrating SWT apps that worked under Windows XP to Windows 7. In particular, Tables seem to look defective under Windows7.

I filed a SWT bug 352042, but no one has even acknowledged it after a month. I'm hoping some of you experts out here can give me some insights.

Thank you!!!

The problem is:

If the Table background is set to be different from the cell background color,
you'll notice that there's a 1-2px crack between two cells that are not filled
with the cell background color, but instead shows the Table Background.

It looks good in XP:

(sorry I'm not allowed to post screenshots here)
But bad in W7:


The eclipse version I'm using is: Build Identifier: 1.3.2.20110218-0812

If I use an SWT jar from 3-4 jars ago, the problem goes away, so it's not a
Windows 7 native rendering problem, but rather some bug in the new SWT jars
with how it interacts with Windows 7.


Reproducible: Always

Steps to Reproduce:
1. Create a Shell
2. Create a Table in the Shell. Set background to back
3. Create a couple of TableItems and color all cell's background to Light Blue
4. Observer the dark column dividing black lines between columns

Previous Topic:How can i hide my browser?
Next Topic:SWT Browser doesn't always paint
Goto Forum:
  


Current Time: Fri Aug 01 18:46:36 EDT 2014

Powered by FUDForum. Page generated in 0.01875 seconds