Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [JET] Select (with dynamic variable) difference from v0.8.1 to v1.1.1 error No Children(JET)
[JET] Select (with dynamic variable) difference from v0.8.1 to v1.1.1 error No Children [message #705932] Sat, 30 July 2011 15:50 Go to next message
Stu Plu is currently offline Stu Plu
Messages: 44
Registered: July 2009
Member
Been a while since I've used JET and taking a working template (that worked with JET version 0.8.1) it doesn't work with JET v1.1.1.

Version 0.8:-
<c:load url="{$org.eclipse.jet.resource.project.name}{$directories}/{$compoundResourceName}.mygmf" var="{$compoundResourceName}" urlContext="workspace" type="mygmf_diagram"/>
<c:dump select="${$compoundResourceName}/*"/>


I added the new loader (as file is a gmf/emf file)

so my Version 1.1.1:-
<c:load url="{$org.eclipse.jet.resource.project.name}{$directories}/{$compoundResourceName}.mygmf" var="{$compoundResourceName}" urlContext="workspace" type="mygmf_diagram" loader="org.eclipse.jet.emf"/>
<c:dump select="${$compoundResourceName}/*"/>
But I get the following error in the dump:-
Status ERROR: org.eclipse.jet code=0 Errors occurred during execution null children=[Status ERROR: org.eclips
e.jet code=0 Could not find value for attribute "ChangeResult/*" Could not find value for attribute "ChangeResult/*"]

If I hard code the variable name like so:-
<c:dump select="$ChangeResult/*" format="true" entities="true"/>

Everything is ok !!

Been a bit stuck on this for a while Sad any help

[Updated on: Mon, 01 August 2011 05:17]

Report message to a moderator

Re: [JET] Select (with dynamic variable) difference from v0.8.1 to v1.1.1 error No Children [message #717672 is a reply to message #705932] Mon, 22 August 2011 02:30 Go to previous message
Stu Plu is currently offline Stu Plu
Messages: 44
Registered: July 2009
Member
Any help with this ? Still stuck
Previous Topic:[Xtend] Is there a type name for collections of collections?
Next Topic:[Acceleo] Resource Factory issue
Goto Forum:
  


Current Time: Fri Sep 19 20:09:13 GMT 2014

Powered by FUDForum. Page generated in 0.01765 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software