Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Integrating the Report Engine to RCP plugin
Integrating the Report Engine to RCP plugin [message #705923] Sat, 30 July 2011 15:36 Go to next message
Johannes.Koshy is currently offline Johannes.Koshy
Messages: 30
Registered: July 2011
Member
I cant get the TargetPlatform to work.
I added all required plugins from the rcp app iam programming a plugin for,
then i deleted all duplicate plugins from the report engine plugins and added the rest to the TargetPlatform via the Directory of the report engine plugins.
Now when unchecking all plugins from the Report Engine directory it starts fine, when starting with the Report Engine plugins in my TargetPlatform the appended error is thrown.
Even though the com.ibm.icu.util plugin is contained within the TargetPlatform since we already use it.
And i had to get the org.eclipse.datatools.modelbase.sql.query_1.1.1.v201008100700 from the 3.7 Birt since it was missing in the 2.6 distribution.

All Tutorials only say to add the dependencies but i cant get even the target platform to work.

Is there anything else i didnt consider when adding the Report Engine plugins to the Target Platform?.
Plz help iam new to this rcp/plugin stuff, its for a intership.

Another Obversation is when validating the plugins prior to run i have some errors with the batik und w3c bundles saying:
org.wc3.dom.svg
Missing Constraint: Require Bundle :org.wc3.dom.smil;bundle-version="0.0.0"

!ENTRY org.eclipse.osgi 4 0 2011-07-29 13:08:38.728

!MESSAGE Anwendungsfehler

!STACK 1

java.lang.NoClassDefFoundError: com/ibm/icu/util/ULocale

at org.eclipse.ui.internal.Workbench$7.run(

Workbench.java:665)

at org.eclipse.core.databinding.observable.Realm.runWithDefault(

Realm.java:332)

at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(

Workbench.java:663)

at org.eclipse.ui.PlatformUI.createAndRunWorkbench(

PlatformUI.java:149)

at com.ceyoniq.admin.core.internal.AdminApplication.start(

AdminApplication.java:39)

at org.eclipse.equinox.internal.app.EclipseAppHandle.run(

EclipseAppHandle.java:196)

at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(

EclipseAppLauncher.java:110)

at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(

EclipseAppLauncher.java:79)

at org.eclipse.core.runtime.adaptor.EclipseStarter.run(

EclipseStarter.java:369)

at org.eclipse.core.runtime.adaptor.EclipseStarter.run(

EclipseStarter.java:179)

at sun.reflect.NativeMethodAccessorImpl.invoke0(

Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at org.eclipse.equinox.launcher.Main.invokeFramework(

Main.java:619)

at org.eclipse.equinox.launcher.Main.basicRun(

Main.java:574)

at org.eclipse.equinox.launcher.Main.run(

Main.java:1407)

at org.eclipse.equinox.launcher.Main.main(

Main.java:1383)

Caused by:

java.lang.ClassNotFoundException: com.ibm.icu.util.ULocale

at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(

BundleLoader.java:460)

at org.eclipse.osgi.internal.loader.BundleLoader.findClass(

BundleLoader.java:422)

at org.eclipse.osgi.internal.loader.BundleLoader.findClass(

BundleLoader.java:410)

at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(

DefaultClassLoader.java:107)

at java.lang.ClassLoader.loadClass(Unknown Source)

... 18 more
Re: Integrating the Report Engine to RCP plugin [message #707356 is a reply to message #705923] Mon, 01 August 2011 14:32 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Have you seen the examples in this download.
http://www.birt-exchange.org/org/devshare/deploying-birt-reports/1344-eclipsecon-2011-api-examples/

In addition to some of the other APIs, there are three RCP applications.
One that shows using the RE API
One that shows using the CE API
One that shows using the Viewer plugin.

Jason

On 7/30/2011 11:36 AM, Johannes.Koshy wrote:
> I cant get the TargetPlatform to work.
> I added all required plugins from the rcp app iam programming a plugin for,
> then i deleted all duplicate plugins from the report engine plugins and
> added the rest to the TargetPlatform via the Directory of the report
> engine plugins.
> Now when unchecking all plugins from the Report Engine directory it
> starts fine, when starting with the Report Engine plugins in my
> TargetPlatform the appended error is thrown.
> Even though the com.ibm.icu.util plugin is contained within the
> TargetPlatform since we already use it.
> And i had to get the
> org.eclipse.datatools.modelbase.sql.query_1.1.1.v201008100700 from the
> 3.7 Birt since it was missing in the 2.6 distribution.
>
> All Tutorials only say to add the dependencies but i cant get even the
> target platform to work.
>
> Is there anything else i didnt consider when adding the Report Engine
> plugins to the Target Platform?.
> Plz help iam new to this rcp/plugin stuff, its for a intership.
>
> Another Obversation is when validating the plugins prior to run i have
> some errors with the batik und w3c bundles saying:
> org.wc3.dom.svg
> Missing Constraint: Require Bundle :org.wc3.dom.smil;bundle-version="0.0.0"
>
>
> !ENTRY org.eclipse.osgi 4 0 2011-07-29 13:08:38.728
>
> !MESSAGE Anwendungsfehler
>
> !STACK 1
>
> java.lang.NoClassDefFoundError: com/ibm/icu/util/ULocale
>
> at org.eclipse.ui.internal.Workbench$7.run(
>
> Workbench.java:665)
>
> at org.eclipse.core.databinding.observable.Realm.runWithDefault(
>
> Realm.java:332)
>
> at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
>
> Workbench.java:663)
>
> at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
>
> PlatformUI.java:149)
>
> at com.ceyoniq.admin.core.internal.AdminApplication.start(
>
> AdminApplication.java:39)
>
> at org.eclipse.equinox.internal.app.EclipseAppHandle.run(
>
> EclipseAppHandle.java:196)
>
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
>
>
> EclipseAppLauncher.java:110)
>
> at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
>
> EclipseAppLauncher.java:79)
>
> at org.eclipse.core.runtime.adaptor.EclipseStarter.run(
>
> EclipseStarter.java:369)
>
> at org.eclipse.core.runtime.adaptor.EclipseStarter.run(
>
> EclipseStarter.java:179)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(
>
> Native Method)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
>
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
>
> at java.lang.reflect.Method.invoke(Unknown Source)
>
> at org.eclipse.equinox.launcher.Main.invokeFramework(
>
> Main.java:619)
>
> at org.eclipse.equinox.launcher.Main.basicRun(
>
> Main.java:574)
>
> at org.eclipse.equinox.launcher.Main.run(
>
> Main.java:1407)
>
> at org.eclipse.equinox.launcher.Main.main(
>
> Main.java:1383)
>
> Caused by:
>
> java.lang.ClassNotFoundException: com.ibm.icu.util.ULocale
>
> at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(
>
> BundleLoader.java:460)
>
> at org.eclipse.osgi.internal.loader.BundleLoader.findClass(
>
> BundleLoader.java:422)
>
> at org.eclipse.osgi.internal.loader.BundleLoader.findClass(
>
> BundleLoader.java:410)
>
> at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(
>
> DefaultClassLoader.java:107)
>
> at java.lang.ClassLoader.loadClass(Unknown Source)
>
> ... 18 more
>
Re: Integrating the Report Engine to RCP plugin [message #707832 is a reply to message #705923] Tue, 02 August 2011 05:38 Go to previous messageGo to next message
Johannes.Koshy is currently offline Johannes.Koshy
Messages: 30
Registered: July 2011
Member
I did get the org.eclipse.birt.examples.rcpengine to work.

But, as i said i cant even add the Birt Report Engine to the Target Platform,
since it seems to Conlflict with ouer plugins or so.

To Circumvent this i used the Report Engine 2.6.0, since all Plugins both, we and the report engine, used had the same version and deleted them in the report engine plugins directory. The com.ibm.icu Jar was one of them.

By now i also fixed the missing constraint message, so by now validating the plugins returns no errors.

When typing ss in the osgi console bevore the crash it return the com.ibm.icu as
active and the report engine plugins as lazy.

So to summarize, with the plugins in ouer Target Platform, the app Crashes on Startup with the above error, without it runs fine.

This is particular strange to me, since i already tried to integrate the Chart Engine with success.


Edit:
Another Update, the birt-rcp-report-designer-2_6_0 does work with ouer rcp application, without even deleting the double plugins :/.

[Updated on: Tue, 02 August 2011 06:54]

Report message to a moderator

Re: Integrating the Report Engine to RCP plugin [message #708384 is a reply to message #707832] Tue, 02 August 2011 18:13 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Is there anyway you could send me a project that reproduces the issue?

Jason

On 8/2/2011 1:38 AM, Johannes.Koshy wrote:
> I did get the org.eclipse.birt.examples.rcpengine to work.
>
> But, as i said i cant even add the Birt Report Engine to the Target
> Platform,
> since it seems to Conlflict with ouer plugins or so.
>
> To Circumvent this i used the Report Engine 2.6.0, since all Plugins
> both, we and the report engine, used had the same version and deleted
> them in the report engine plugins directory. The com.ibm.icu Jar was one
> of them.
>
> By now i also fixed the missing constraint message, so by now validating
> the plugins returns no errors.
>
> When typing ss in the osgi console bevore the crash it return the
> com.ibm.icu as
> active and the report engine plugins as lazy.
>
> So to summarize, with the plugins in ouer Target Platform, the app
> Crashes on Startup with the above error, without it runs fine.
>
> This is particular strange to me, since i already tried to integrate the
> Chart Engine with success.
>
>
Re: Integrating the Report Engine to RCP plugin [message #708884 is a reply to message #708384] Wed, 03 August 2011 08:57 Go to previous message
Johannes.Koshy is currently offline Johannes.Koshy
Messages: 30
Registered: July 2011
Member
sry i will not be able to that Sad.

But since i got the Designer Package to run i can try to reduce it later on.

thank you
Previous Topic:Report generation process
Next Topic:Parameter that decides wich table show
Goto Forum:
  


Current Time: Mon Sep 22 18:17:14 GMT 2014

Powered by FUDForum. Page generated in 0.15190 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software