Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Technology Project and PMC » Hi
Hi [message #72816] Thu, 22 June 2006 21:42 Go to next message
Eclipse User
Originally posted by: mperalta8.hotmail.com

I need help, I try to use ant in eclipse sdk but whend I send a
compilation, in the console apears these message:

and cannot see what is the fail, I have install sdk1.4.2_12 and I use
eclipse 3.1.2

Regards

BUILD FAILED

C:\fixj\quickfixj\build.xml:129: Unable to find a javac compiler;

com.sun.tools.javac.Main is not on the classpath.

Perhaps JAVA_HOME does not point to the JDK

Total time: 3 seconds
Re: Hi [message #72832 is a reply to message #72816] Fri, 23 June 2006 08:04 Go to previous message
Eclipse User
Originally posted by: eclipse.bettsockentraeger.de

Have you added the jdk under Preferences -> Java -> Installed JRE's? Is
it selected? If not add it there and check it so that eclipse actually
uses the jdk and not the jre.

Next check if the ant runtime is setup. Preferences -> Ant -> Runtime It
should point to the ant plugin distributed with eclispe (this is as far
as I know default). If it doesn't point to the ant plugin or an ant
installation. Look in the plugin folder in your eclipse installation for
a plugin org.apache.ant_xxx where xxx is the version It should be 1.6.5
or so for Eclipse 3.1.2

Regards
Stefan

Miguel Peralta wrote:
> I need help, I try to use ant in eclipse sdk but whend I send a
> compilation, in the console apears these message:
>
> and cannot see what is the fail, I have install sdk1.4.2_12 and I use
> eclipse 3.1.2
>
> Regards
>
> BUILD FAILED
>
> C:\fixj\quickfixj\build.xml:129: Unable to find a javac compiler;
>
> com.sun.tools.javac.Main is not on the classpath.
>
> Perhaps JAVA_HOME does not point to the JDK
>
> Total time: 3 seconds
>
>
>
>
>
>
Re: Hi [message #600830 is a reply to message #72816] Fri, 23 June 2006 08:04 Go to previous message
Stefan Langer is currently offline Stefan Langer
Messages: 236
Registered: July 2009
Senior Member
Have you added the jdk under Preferences -> Java -> Installed JRE's? Is
it selected? If not add it there and check it so that eclipse actually
uses the jdk and not the jre.

Next check if the ant runtime is setup. Preferences -> Ant -> Runtime It
should point to the ant plugin distributed with eclispe (this is as far
as I know default). If it doesn't point to the ant plugin or an ant
installation. Look in the plugin folder in your eclipse installation for
a plugin org.apache.ant_xxx where xxx is the version It should be 1.6.5
or so for Eclipse 3.1.2

Regards
Stefan

Miguel Peralta wrote:
> I need help, I try to use ant in eclipse sdk but whend I send a
> compilation, in the console apears these message:
>
> and cannot see what is the fail, I have install sdk1.4.2_12 and I use
> eclipse 3.1.2
>
> Regards
>
> BUILD FAILED
>
> C:\fixj\quickfixj\build.xml:129: Unable to find a javac compiler;
>
> com.sun.tools.javac.Main is not on the classpath.
>
> Perhaps JAVA_HOME does not point to the JDK
>
> Total time: 3 seconds
>
>
>
>
>
>
Previous Topic:Hi
Next Topic:RAP+RSP+Wicket
Goto Forum:
  


Current Time: Tue Sep 16 19:38:16 GMT 2014

Powered by FUDForum. Page generated in 0.03405 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software