Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Target Management » Connection to a remote application wont show up
Connection to a remote application wont show up [message #703121] Wed, 27 July 2011 07:42 Go to next message
dschingis is currently offline dschingis
Messages: 2
Registered: July 2011
Junior Member
Hello everyone,

I've got a small problem with RSE project in conjunction with the CDT.

At first the setup: I'm working on Ubuntu 10.04 (although i tried windows 7 too). The target system is a FPGA running uClinux.
The "manual" mode works, meaning compiling in Eclipse (Indigo Release) upload the file with ftp, starting the gdbserver and connect/debug with eclipse.

I found this nice project which should do these steps itself. The problem is now, i can't choose the target connection in the Remote Application Settings:
Pic of the dropdownlist:
h**p://i51.tinypic.com/2aifxhu.jpg



Now i can't change the properties of local and i can't see any of the connections created. But i can see all created connections when browsing for the remote absolute file path:
h**p://i53.tinypic.com/34zd65s.jpg


So the connection should be there and should work (at least when browsing for the path the ftp log in the background works) but for some reason i just can't see them when choosing the target.

Anyone any idea why? Have i done anything wrong? Any help would be appreciated.

Cheers

PS. sorry for the h**p, but the system wont let me use links (until 5 posts) ...

[Updated on: Wed, 27 July 2011 07:42]

Report message to a moderator

Re: Connection to a remote application wont show up [message #703147 is a reply to message #703121] Wed, 27 July 2011 08:24 Go to previous messageGo to next message
Martin Oberhuber is currently offline Martin Oberhuber
Messages: 984
Registered: July 2009
Senior Member
I think the problem is that just uploading your code won't do, because the Launch also needs to start gdbserver on the remote. Therefore the connection needs to support both "file transfer" and "shell" access - your FTP connection only supports "file transfer", therefore it isn't listed.

You'll probably want to create a connection of type "Linux", then choose "FTP" for file transfer and "Telnet" for shell access.

Also note that the "remote launch" is now managed by CDT so if you want to file a bug or enhancement request you should file it against CDT.
Re: Connection to a remote application wont show up [message #703155 is a reply to message #703147] Wed, 27 July 2011 08:31 Go to previous message
dschingis is currently offline dschingis
Messages: 2
Registered: July 2011
Junior Member
aw this already checks that it will need shellsupport.

well i tried and it works now thanks Smile
Previous Topic:Solved: Application not found
Next Topic:Questions about debugging on target via Target Management vs typical CDT
Goto Forum:
  


Current Time: Wed Oct 01 16:34:02 GMT 2014

Powered by FUDForum. Page generated in 0.02133 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software