Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dali » JPA Diagram editor 0.5.0 not working with Graphiti 0.8.0(Issues with JPA diagram: org.eclipse.swt.SWTException)
JPA Diagram editor 0.5.0 not working with Graphiti 0.8.0 [message #702595] Tue, 26 July 2011 14:59 Go to next message
Olivier Mising name is currently offline Olivier Mising nameFriend
Messages: 3
Registered: July 2011
Junior Member
Hi,

Please excuse me if this is'nt the right place for that question, it's my first post on this forum.

I can't run JPA Diagram Editor anymore because I am getting the following exception when opening a JPA diagram in Eclipse:
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NoSuchMethodError: org/eclipse/graphiti/services/IGaService.createDefaultText(Lorg/eclipse/graphiti/mm/GraphicsAlgorithmContainer;Ljava/lang/String;)Lorg/eclipse/graphiti/mm/algorithms/Text;)

So, I thought it had to do with Graphiti versioning but I updated everything to the latest version:
JPA Diagram Editor => 0.5.0.201012011111
Graphiti => 0.8.0.v20110607-1252

No better.

Any idea? I'm stuck with no graphical editor for my JPA mappings, pretty annoying to code...

Thanks!!
Re: JPA Diagram editor 0.5.0 not working with Graphiti 0.8.0 [message #707288 is a reply to message #702595] Mon, 01 August 2011 12:53 Go to previous messageGo to next message
Stefan Dimov is currently offline Stefan DimovFriend
Messages: 14
Registered: July 2009
Location: Sofia, Bulgaria
Junior Member
Hello Olivier,

And why are you using the JPA Editor 0.5.0? There is a newer version that was released with Indigo. Graphiti 0.8.0 is the newest version of Graphiti and it's most certainly not compatible with the JPA Editor 0.5.0. I would advise you to use the latest version of the JPA Editor that was released with Indigo.

If you are using Helios, then Graphiti 0.8.0 is not the proper Graphiti version for you. You have to uninstall it and install the older version 0.7.2 using this update site:

http://download.eclipse.org/graphiti/updates/0.7.2/

The JPA Diagram Editor 0.5.0 works fine with this version of Graphiti.

Regards,
Stefan

[Updated on: Mon, 01 August 2011 13:59]

Report message to a moderator

Re: JPA Diagram editor 0.5.0 not working with Graphiti 0.8.0 [message #708805 is a reply to message #707288] Wed, 03 August 2011 07:33 Go to previous message
Olivier Mising name is currently offline Olivier Mising nameFriend
Messages: 3
Registered: July 2011
Junior Member
Thanks Stefan for your reply.

What I was trying to do, in fact, was to install IBM RAD "on top of" an existing Eclipse 3.6. RAD wouldn't want to do this on Eclipse 3.7.

But anyway... after hours of trying I managed to have it and... there were bugs.

So I just gave up, installed RAD with its own Eclipse 3.6 included, and everything was fine again: I could install Graphiti and JPA editor fine (but version 0.5.0 because I think you can't install the version that was released with Indigo on a 3.6).

So, things are back in order.

BTW, JPA Diagram editor 0.5.0 does work with Graphiti 0.8.0. I think it was due to something else on my messy install of RAD + Eclipse.

Thanks!

Olivier
Previous Topic:Unable to generate JAXB classes
Next Topic:Using Dali annotation processor from a maven build
Goto Forum:
  


Current Time: Sat Dec 20 00:24:30 GMT 2014

Powered by FUDForum. Page generated in 0.05174 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software