Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [XTend] Couldn' t resolve type for....(Want to test a simple M2M with two ecore metamodelfiles)
[XTend] Couldn' t resolve type for.... [message #702495] Tue, 26 July 2011 12:59 Go to next message
gibtsdennsowas is currently offline gibtsdennsowas
Messages: 3
Registered: July 2011
Junior Member
hi folks,

i want to test a m2m:
i have a generator project containing the model file (i just followed the tutorials on the net to create my dsl).

now i want to create a transformation from my tutorial-metamodel mm1 to another metamodel mm2(i only have the ecore file for mm2).
i just wrote my create extensions, no warning, everythings seems to be fine.
but when i execute the workflow

	component = org.eclipse.xtext.mwe.Reader {
		// lookup all resources on the classpath
		// useJavaClassPath = true
		
		// or define search scope explicitly
		path = modelPath
		
		// this class will be generated by the xtext generator 
		register = org.xtext.example.MyDslStandaloneSetup {}
		useJavaClassPath = true
		resourceDescriptionsProvider = org.eclipse.xtext.mwe.ResourceDescriptionsProvider{ }
		
		load = {
			slot = "model"
			type = "Model"
		}
	}

component = org.eclipse.xtend.XtendComponent {
   metaModel = org.eclipse.xtend.type.impl.java.JavaBeansMetaModel{}
   invoke="transformation::transformation::toMM2(model)"
   outputSlot="transformedModel"
}


an error occurs:
ERROR org.eclipse.xtend.XtendComponent - Error in Component of type org.eclipse.xtend.XtendComponent:
EvaluationException : Couldn't resolve type Graph

"Graph" is a type of MM2.
i just have no idea how to configure everything, so i can use the mm2 ecore to execute the transformation.

mm1.ecore and mm2.ecore are placed in the src-gen folder of the mm1-tutorial project.
note: mm2.ecore is a hand written metamodel (not generated with xtext).

can anybody help me? what im doing wrong?

thanks for your time and help!

all the best



edit: im working with xtext 1.0.1

[Updated on: Wed, 27 July 2011 13:12]

Report message to a moderator

Re: [XTend] Couldn' t resolve type for.... [message #703316 is a reply to message #702495] Wed, 27 July 2011 12:45 Go to previous message
gibtsdennsowas is currently offline gibtsdennsowas
Messages: 3
Registered: July 2011
Junior Member
solved. the M2M is working in combination with ecore, so i couldnt use JavaBeansMetaModel.
Use EmfMetaModel or EmfRegistryMetaModel instead.
thread can be closed.
Previous Topic:trouble with this bug
Next Topic:[ATL] Reusing transformation rules defined on an ecore model that is being extended
Goto Forum:
  


Current Time: Sat Oct 25 02:50:14 GMT 2014

Powered by FUDForum. Page generated in 0.02318 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software