Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Error exporting a papyrus plugin from svn(need some help please)
Error exporting a papyrus plugin from svn [message #698901] Wed, 20 July 2011 08:42 Go to next message
Miriam  is currently offline Miriam
Messages: 29
Registered: April 2011
Junior Member
Hi,
I used to check out the org.eclipse.papyrus.diagram.sequence from the svn, do some changes and then export the plugin and put the .jar in the folder plugin of eclipse replacing the "original" .jar of papyrus. I could do some changes, but since 2 or 3 weeks (I think after an update) everytime I do this, I have this error log, and I never can display my diagrams. I even tried to export the plugin from the svn, and export it without changing anything in the code, the result is the same error log. Can I have some help, or explanation??
Thanks

Miriam




java.lang.IllegalArgumentException: No Part found for the model 'org.eclipse.papyrus.sashwindows.di.impl.PageRefImpl@1e58f4d4 (objectPageIdentifier: null)'
at org.eclipse.papyrus.sasheditor.internal.SashWindowsContainer.createPagePart(SashWindowsContainer.java:271)
at org.eclipse.papyrus.sasheditor.internal.TabFolderPart.createChildPart(TabFolderPart.java:899)
at org.eclipse.papyrus.sasheditor.internal.TabFolderPart.createTabItem(TabFolderPart.java:828)
at org.eclipse.papyrus.sasheditor.internal.TabFolderPart.synchronize2(TabFolderPart.java:743)
at org.eclipse.papyrus.sasheditor.internal.RootPart.synchronize2(RootPart.java:139)
at org.eclipse.papyrus.sasheditor.internal.SashWindowsContainer.refreshTabsInternal(SashWindowsContainer.java:386)
at org.eclipse.papyrus.sasheditor.internal.SashWindowsContainer.refreshTabs(SashWindowsContainer.java:339)
at org.eclipse.papyrus.sasheditor.internal.SashWindowsContainer.createPartControl(SashWindowsContainer.java:169)
at org.eclipse.papyrus.sasheditor.editor.AbstractMultiPageSashEditor.createPartControl(AbstractMultiPageSashEditor.java:130)
at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:670)
at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
at org.eclipse.ui.internal.EditorAreaHelper.setVisibleEditor(EditorAreaHelper.java:271)
at org.eclipse.ui.internal.EditorManager.setVisibleEditor(EditorManager.java:1429)
at org.eclipse.ui.internal.EditorManager$5.runWithException(EditorManager.java:942)
at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3593)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3286)
at org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:803)
at org.eclipse.ui.internal.Workbench$31.runWithException(Workbench.java:1567)
at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3593)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3286)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2548)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
Re: Error exporting a papyrus plugin from svn [message #699367 is a reply to message #698901] Thu, 21 July 2011 08:36 Go to previous messageGo to next message
Cedric Dumoulin is currently offline Cedric Dumoulin
Messages: 34
Registered: July 2009
Member
Hi,

The PageIdentifier is used by the sashWindowsContainer to know which
diagram editor should be used to open your diagram. If the identifier is
not found, or is wrong, the sashWindowsContainer can't open the diagram.
It can happen when there is some errors in the .di file.

Have you try to create your sequence diagram in a new Papyrus model ?
Does this work ? If yes, you certainly have an error in the .di file.

Does the model explorer success to open ? If yes, try to close the
diagram, and reopen it from the model explorer.

Hope this help,
Cedric

Miriam a écrit :
> Hi,
> I used to check out the org.eclipse.papyrus.diagram.sequence from the
> svn, do some changes and then export the plugin and put the .jar in the
> folder plugin of eclipse replacing the "original" .jar of papyrus. I
> could do some changes, but since 2 or 3 weeks (I think after an update)
> everytime I do this, I have this error log, and I never can display my
> diagrams. I even tried to export the plugin from the svn, and export it
> without changing anything in the code, the result is the same error log.
> Can I have some help, or explanation??
> Thanks
>
> Miriam
>
>
>
>
> java.lang.IllegalArgumentException: No Part found for the model
> mailto:'org.eclipse.papyrus.sashwindows.di.impl.PageRefImpl@1e58f4d4
> (objectPageIdentifier: null)'
> at
> org.eclipse.papyrus.sasheditor.internal.SashWindowsContainer.createPagePart(SashWindowsContainer.java:271)
>
> at
> org.eclipse.papyrus.sasheditor.internal.TabFolderPart.createChildPart(TabFolderPart.java:899)
>
> at
> org.eclipse.papyrus.sasheditor.internal.TabFolderPart.createTabItem(TabFolderPart.java:828)
>
> at
> org.eclipse.papyrus.sasheditor.internal.TabFolderPart.synchronize2(TabFolderPart.java:743)
>
> at
> org.eclipse.papyrus.sasheditor.internal.RootPart.synchronize2(RootPart.java:139)
>
> at
> org.eclipse.papyrus.sasheditor.internal.SashWindowsContainer.refreshTabsInternal(SashWindowsContainer.java:386)
>
> at
> org.eclipse.papyrus.sasheditor.internal.SashWindowsContainer.refreshTabs(SashWindowsContainer.java:339)
>
> at
> org.eclipse.papyrus.sasheditor.internal.SashWindowsContainer.createPartControl(SashWindowsContainer.java:169)
>
> at
> org.eclipse.papyrus.sasheditor.editor.AbstractMultiPageSashEditor.createPartControl(AbstractMultiPageSashEditor.java:130)
>
> at
> org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:670)
>
> at
> org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)
>
> at
> org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
>
> at
> org.eclipse.ui.internal.EditorAreaHelper.setVisibleEditor(EditorAreaHelper.java:271)
>
> at
> org.eclipse.ui.internal.EditorManager.setVisibleEditor(EditorManager.java:1429)
>
> at
> org.eclipse.ui.internal.EditorManager$5.runWithException(EditorManager.java:942)
>
> at
> org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
>
> at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
> at
> org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
>
> at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3593)
> at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3286)
> at
> org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:803)
>
> at
> org.eclipse.ui.internal.Workbench$31.runWithException(Workbench.java:1567)
> at
> org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
>
> at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
> at
> org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
>
> at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3593)
> at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3286)
> at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2548)
> at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
> at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
> at
> org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
>
> at
> org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
> at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
> at
> org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
>
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
>
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
>
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
>
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
>
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
>
Re: Error exporting a papyrus plugin from svn [message #699374 is a reply to message #699367] Thu, 21 July 2011 09:03 Go to previous messageGo to next message
Miriam  is currently offline Miriam
Messages: 29
Registered: April 2011
Junior Member
It doesn't work Sad
actually, when I replace the org.eclipse.papyrus.diagram.sequence_0.7.3.v201104270854.jar (of the folder plugin of eclipse) by the org.eclipse.papyrus.diagram.sequence_0.7.3.vxxxxxxxxx.jar (import the plug in from the svn and export the .jar to replace the original one, I just rename the .jar exported to be exactly 0.7.3.v201104270854, it used to work for me like that). I am doing it wrong (i Think yes).
the errors are still the same, and when I open the model explorer and do model -> right click -> new diagram, the sequence diagram doesn't appear at all in the list...
what can I do, to import this plugin from svn, to change the code and to use it in papyrus instead of the original rg.eclipse.papyrus.diagram.sequence_0.7.3.v201104270854??
Thanks a lot

Miriam
Re: Error exporting a papyrus plugin from svn [message #699384 is a reply to message #699374] Thu, 21 July 2011 09:20 Go to previous messageGo to next message
Cedric Dumoulin is currently offline Cedric Dumoulin
Messages: 34
Registered: July 2009
Member
I have heard that some developpers wanting to modify only one diagram
proceed as the following:
- setup an Eclipse environement (modeling)
- install the required Papyrus by using the appropriate update site
repository (Help->Install New Software)
- then import the diagram from SVN
- do the modification
- try the new diagram by running it in an Eclipse runtimeApplication
(Run As->Eclipse Application)

Have you try this solution ?

Miriam a écrit :
> It doesn't work :(
> actually, when I replace the
> org.eclipse.papyrus.diagram.sequence_0.7.3.v201104270854.jar (of the
> folder plugin of eclipse) by the
> org.eclipse.papyrus.diagram.sequence_0.7.3.vxxxxxxxxx.jar (import the
> plug in from the svn and export the .jar to replace the original one, I
> just rename the .jar exported to be exactly 0.7.3.v201104270854, it used
> to work for me like that). I am doing it wrong (i Think yes).
> the errors are still the same, and when I open the model explorer and do
> model -> right click -> new diagram, the sequence diagram doesn't appear
> at all in the list...
> what can I do, to import this plugin from svn, to change the code and to
> use it in papyrus instead of the original
> rg.eclipse.papyrus.diagram.sequence_0.7.3.v201104270854??
> Thanks a lot
>
> Miriam
Re: Error exporting a papyrus plugin from svn [message #699434 is a reply to message #699384] Thu, 21 July 2011 10:36 Go to previous messageGo to next message
Miriam  is currently offline Miriam
Messages: 29
Registered: April 2011
Junior Member
I will try this, then let you know about the result..
Re: Error exporting a papyrus plugin from svn [message #699842 is a reply to message #699434] Fri, 22 July 2011 08:35 Go to previous messageGo to next message
Miriam  is currently offline Miriam
Messages: 29
Registered: April 2011
Junior Member
I tried this solution, and it works! Smile
but it works only in Eclipse runtimeApplication, how can I make it work for all my Papyrus projects?
Thanks

Miriam
Re: Error exporting a papyrus plugin from svn [message #699865 is a reply to message #699842] Fri, 22 July 2011 09:55 Go to previous messageGo to next message
Cedric Dumoulin is currently offline Cedric Dumoulin
Messages: 34
Registered: July 2009
Member
So your code is ok.
The problem should be in the way you build the jar or in the way you
integrate it in the existing Eclipse.
Check what is inside the jar. compare with the original one: is the
plugin.xml file here ? It is mandatory, has it contains the informations
to register your editor.

Hope this help,
Cedric

Miriam a écrit :
> I tried this solution, and it works! :)
> but it works only in Eclipse runtimeApplication, how can I make it work
> for all my Papyrus projects?
> Thanks
>
> Miriam
Re: Error exporting a papyrus plugin from svn [message #699870 is a reply to message #699865] Fri, 22 July 2011 10:06 Go to previous message
Miriam  is currently offline Miriam
Messages: 29
Registered: April 2011
Junior Member
now it works, i give the new jar exactly the same qualifier as the original.
thanks for your help ^^
Previous Topic:Access to selected object on the diagram editor from Java code
Next Topic:Papyrus and proprietary metamodel
Goto Forum:
  


Current Time: Wed Jul 23 06:07:32 EDT 2014

Powered by FUDForum. Page generated in 0.02230 seconds