Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Papyrus installation bugs.
Papyrus installation bugs. [message #698873] Wed, 20 July 2011 12:13 Go to next message
Wojciech Trocki is currently offline Wojciech TrockiFriend
Messages: 64
Registered: May 2010
Member
There is any possibility to install papyrus without JDT and PDE?
This dependencies are used by papyrus?
I work with modeling elements on devices witch have small amount of ram and disk space. When installing papyrus on eclipse product, it's size grows up to 200 mb.
With papyrus installs also JDT and PDE which is unused in standard modeling.
And this is my question. Is this dependencies required to work with papyrus class and sequence diagrams? How to prevent from installing this plugins.( In update site I choose only class diagram and papyrus barebone features and this also installs JDT Sad(( ). For me installations should be more customizable.

[Updated on: Wed, 20 July 2011 12:14]

Report message to a moderator

Re: Papyrus installation bugs. [message #699355 is a reply to message #698873] Thu, 21 July 2011 12:17 Go to previous messageGo to next message
Cedric Dumoulin is currently offline Cedric DumoulinFriend
Messages: 35
Registered: July 2009
Member
Hi,

You are right, in theory there is no reasons for Papyrus to use JDT
ot PDE.
If you check the oep.diagram.clazz dependencies, and dig in the
dependencies analysis, you can see that JDT is listed. It means that one
of the plugins declare it. Unfortunately, the tool doesn't allows to
trace who is declaring it :-(. This needs more investigations to check
if we can break this import.

Cedric


Wojciech Trocki a écrit :
> There is any possibility to install papyrus without JDT and PDE?
> This dependencies are used by papyrus?
> I work with modeling elements on devices witch have small amount of ram
> and disk space. When installing papyrus on eclipse product, it's size
> grows up to 200 mb. With papyrus installs also JDT and PDE which is
> unused in standard modeling. And this is my question. Is this
> dependencies required to work with papyrus class and sequence diagrams?
> How to prevent from installing this plugins.( In update site I choose
> only class diagram and papyrus barebone features and this also installs
> JDT :((( ). For me installations should be more customizable.
Re: Papyrus installation bugs. [message #704095 is a reply to message #698873] Thu, 28 July 2011 09:20 Go to previous messageGo to next message
Wojciech Trocki is currently offline Wojciech TrockiFriend
Messages: 64
Registered: May 2010
Member
I found that model explorer depends on org.eclipse.emf.facet.infra.query.ui which depends on jdt.ui

org.eclipse.emf.mwe2.launch use jdt.debug.ui. This depenency spread across all papyrus diagrams.

PDE depends on papyrus.common Smile
Re: Papyrus installation bugs. [message #704688 is a reply to message #704095] Fri, 29 July 2011 00:19 Go to previous messageGo to next message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1340
Registered: July 2009
Senior Member
It's hard to avoid JDT. Smile Xtext has one too and it drives me nuts. Are you sure that the dependency isn't optional though?
Re: Papyrus installation bugs. [message #704689 is a reply to message #704095] Fri, 29 July 2011 00:19 Go to previous messageGo to next message
Miles Parker is currently offline Miles ParkerFriend
Messages: 1340
Registered: July 2009
Senior Member
Wojciech Trocki wrote on Thu, 28 July 2011 05:20

PDE depends on papyrus.common Smile


Please tell me you're kidding, right?
Re: Papyrus installation bugs. [message #707158 is a reply to message #704689] Mon, 01 August 2011 10:01 Go to previous messageGo to next message
Wojciech Trocki is currently offline Wojciech TrockiFriend
Messages: 64
Registered: May 2010
Member
Quote:
Please tell me you're kidding, right?


Sorry. Wrong direction. Papyrus common depends on PDE Smile
icon5.gif  Re: Papyrus installation bugs. [message #707160 is a reply to message #704689] Mon, 01 August 2011 10:04 Go to previous message
Wojciech Trocki is currently offline Wojciech TrockiFriend
Messages: 64
Registered: May 2010
Member
Quote:
Please tell me you're kidding, right?


My mistake. Wrong direction.There should be: Papyrus common depends on PDE Smile
(no subject) [message #707180 is a reply to message #704689] Mon, 01 August 2011 10:01 Go to previous message
Wojciech Trocki is currently offline Wojciech TrockiFriend
Messages: 64
Registered: May 2010
Member
Quote:
> Please tell me you're kidding, right?


Sorry. Wrong direction. Papyrus common depends on PDE :)
(no subject) [message #707181 is a reply to message #704689] Mon, 01 August 2011 10:04 Go to previous message
Wojciech Trocki is currently offline Wojciech TrockiFriend
Messages: 64
Registered: May 2010
Member
Quote:
> Please tell me you're kidding, right?


My mistake. Wrong direction.There should be: Papyrus common depends on PDE :)
(no subject) [message #707188 is a reply to message #704689] Mon, 01 August 2011 10:01 Go to previous message
Wojciech Trocki is currently offline Wojciech TrockiFriend
Messages: 64
Registered: May 2010
Member
Quote:
> Please tell me you're kidding, right?


Sorry. Wrong direction. Papyrus common depends on PDE :)
(no subject) [message #707189 is a reply to message #704689] Mon, 01 August 2011 10:04 Go to previous message
Wojciech Trocki is currently offline Wojciech TrockiFriend
Messages: 64
Registered: May 2010
Member
Quote:
> Please tell me you're kidding, right?


My mistake. Wrong direction.There should be: Papyrus common depends on PDE :)
(no subject) [message #707238 is a reply to message #704689] Mon, 01 August 2011 10:01 Go to previous message
Wojciech Trocki is currently offline Wojciech TrockiFriend
Messages: 64
Registered: May 2010
Member
Quote:
> Please tell me you're kidding, right?


Sorry. Wrong direction. Papyrus common depends on PDE :)
(no subject) [message #707240 is a reply to message #704689] Mon, 01 August 2011 10:04 Go to previous message
Wojciech Trocki is currently offline Wojciech TrockiFriend
Messages: 64
Registered: May 2010
Member
Quote:
> Please tell me you're kidding, right?


My mistake. Wrong direction.There should be: Papyrus common depends on PDE :)
Previous Topic:get UML2 Element from its EditPart
Next Topic:Instance Specification issues
Goto Forum:
  


Current Time: Fri Nov 28 19:34:33 GMT 2014

Powered by FUDForum. Page generated in 0.03460 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software