Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » SVN Version
SVN Version [message #6373] Thu, 09 November 2006 20:06 Go to next message
Adam Cabler is currently offline Adam Cabler
Messages: 113
Registered: July 2009
Senior Member
Just wondering if anyone knows what version of svn is currently being
targetted?
Re: SVN Version [message #6394 is a reply to message #6373] Sun, 12 November 2006 11:22 Go to previous messageGo to next message
Igor Vinnykov is currently offline Igor Vinnykov
Messages: 61
Registered: July 2009
Member
Dear Adam,

Currently Subversive supports 1.1, 1.2, 1.3 and 1.4 versions of SVN.
Support of particular SVN version depends on client library version, which
is used.

1.1.x stream:
Extended JavaSVN: SVN 1.1, 1.2 and 1.3
Standard JavaSVN: SVN 1.1, 1.2, 1.3 and 1.4
JavaHL: SVN 1.1, 1.2, 1.3 and 1.4

1.0.x stream:
Extended JavaSVN: SVN 1.1, 1.2 and 1.3

We are going to create new 1.0.4 build soon, so it allows working with
different SVN client libraries (standard JavaSVN and JavaHL) and will
provide SVN 1.4 support.

Subversive proposal published on eclipse.org doesn't target to particular
SVN version. The scope of proposal is wider and supposed that plug-in will
evaluate together with SVN.

Best regards,
Igor Vinnykov
Subversive Team


AdamC wrote:

> Just wondering if anyone knows what version of svn is currently being
> targetted?
Re: SVN Version [message #6468 is a reply to message #6394] Mon, 13 November 2006 11:47 Go to previous message
Adam Cabler is currently offline Adam Cabler
Messages: 113
Registered: July 2009
Senior Member
Great - exactly what I needed.

thanks!

Igor Vinnykov wrote:
> Dear Adam,
>
> Currently Subversive supports 1.1, 1.2, 1.3 and 1.4 versions of SVN.
> Support of particular SVN version depends on client library version,
> which is used.
>
> 1.1.x stream:
> Extended JavaSVN: SVN 1.1, 1.2 and 1.3
> Standard JavaSVN: SVN 1.1, 1.2, 1.3 and 1.4
> JavaHL: SVN 1.1, 1.2, 1.3 and 1.4
>
> 1.0.x stream:
> Extended JavaSVN: SVN 1.1, 1.2 and 1.3
>
> We are going to create new 1.0.4 build soon, so it allows working with
> different SVN client libraries (standard JavaSVN and JavaHL) and will
> provide SVN 1.4 support.
>
> Subversive proposal published on eclipse.org doesn't target to
> particular SVN version. The scope of proposal is wider and supposed that
> plug-in will evaluate together with SVN.
>
> Best regards,
> Igor Vinnykov
> Subversive Team
>
>
> AdamC wrote:
>
>> Just wondering if anyone knows what version of svn is currently being
>> targetted?
>
>
Previous Topic:Why Subversive?
Next Topic:Why I favor Subclipse over Subversive.
Goto Forum:
  


Current Time: Thu Jul 31 07:36:31 EDT 2014

Powered by FUDForum. Page generated in 0.01537 seconds