Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » (no subject)
(no subject) [message #698458] Tue, 19 July 2011 14:07 Go to next message
David Wynter is currently offline David WynterFriend
Messages: 4578
Registered: July 2009
Senior Member
Hi,

Looked for this in the forum and documentation, could not see an answer
to this. I start with a new empty OSGi style Debug config. I add my main
bundle and click "Add required plugins" then "Validate plugins". Then I
run it with the std args provided by the New command for a OSGi debug
configuration.

It tries to run my bundle and then outputs about 200 of these, 1 for
each project in my workspace.

>FULL BUILD STATS for: DbUnit
> compiled 76962 lines in 3260ms:23607.9lines/s
> parse: 826 ms (25.3%), resolve: 1807 ms (55.4%), analyze: 0 ms
(0.0%), generate: 273 ms (8.3%)


I cannot see where OSGi is configured to build everything in sight each
time I start it. Where is this, or how can I stop it.

Thx.

David
(no subject) [message #698518 is a reply to message #698458] Tue, 19 July 2011 15:20 Go to previous messageGo to next message
Gunnar Wagenknecht is currently offline Gunnar WagenknechtFriend
Messages: 452
Registered: July 2009
Location: Germany ✈ Vancouver
Senior Member

Hi David,

Am 19.07.2011 16:07, schrieb David Wynter:
> I cannot see where OSGi is configured to build everything in sight each
> time I start it. Where is this, or how can I stop it.

There is a global preference option for this.
Window -> Preferences -> Run/Debug -> Launching

-Gunnar

--
Gunnar Wagenknecht
gunnar@wagenknecht.org
http://wagenknecht.org/
(no subject) [message #698543 is a reply to message #698518] Tue, 19 July 2011 15:48 Go to previous message
David Wynter is currently offline David WynterFriend
Messages: 4578
Registered: July 2009
Senior Member
On 19/07/11 16:20, Gunnar Wagenknecht wrote:
> Hi David,
>
> Am 19.07.2011 16:07, schrieb David Wynter:
>> I cannot see where OSGi is configured to build everything in sight each
>> time I start it. Where is this, or how can I stop it.
>
> There is a global preference option for this.
> Window -> Preferences -> Run/Debug -> Launching
>
> -Gunnar
>
Hi,

Yes, thanks for that. It is not the problem. By default it appears that
the OSGi debug New command uses the users home directory as a default
working directory. Then somehow it finds my workspace directly under
that and then compiles all projects in that workspace due to the option
you pointed out.

What you actually need to do is set the working directory to a directory
somewhere where there are no projects other than the bundle you want to
run. In my case I have a sub directory of that - ./etc and in there I
have my jetty,xml and realms.properties.

The documentation needs to explain this somewhere...

Thx.

David
Previous Topic:update process error
Next Topic:How to install Equinox
Goto Forum:
  


Current Time: Sun Nov 23 02:21:30 GMT 2014

Powered by FUDForum. Page generated in 0.01572 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software