Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » update process error
update process error [message #698306] Tue, 19 July 2011 04:35
Carmelo  is currently offline Carmelo
Messages: 224
Registered: July 2009
Senior Member
I all
Hope someone can help me with the update process .

I have an rcp project with the p2 update mechanism.

There is a

- Product / rcp (main plugin)
- Plugin 1
- Plugin 2

If I use define all the plugin and the product with version
a.b.c.qualifier . and I replace the qualifier with the v.time.date version
during the building . I get a p2 update site perfectly working. Clearly in
this way every time all the application will be updated (each time a rebuild
the whole plug-ins are new even if I have not changed anything).

If instead I use as versioning a.b.c.d . let's say I update plugin 1 . from
1.2.3.4 to 1.2.3.5

If I just rebuild the whole application I publish the new p2 site . no
update will performed .. And if I try to perform a new install I get this

(in the following example I have changed the following plugin)

Automator 1.7.8.4 (com.media.mwb.automator 1.7.8.4)
Automator 1.7.8.3 (com.media.mwb.automator 1.7.8.3)

I have tried to udate at the same time (either just the product version . or
the main plugin . and both of them) . still error :(




Your original request has been modified.
"Workbench Automator" is already installed, so an update will be performed
instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: Workbench Automator 1.7.8.4
(com.media.feature.mwb.automator.feature.group 1.7.8.4)
Software currently installed: Méthode Workbench 4.5.1.1 (MWB Product
4.5.1.1)
Only one of the following can be installed at once:
Automator 1.7.8.4 (com.media.mwb.automator 1.7.8.4)
Automator 1.7.8.3 (com.media.mwb.automator 1.7.8.3)
Cannot satisfy dependency:
From: Méthode Workbench 4.5.1.1 (MWB Product 4.5.1.1)
To: com.media.feature.mwb.inspectorcmdbridge.feature.group [1.0.4.1]
Cannot satisfy dependency:
From: Workbench Automator 1.7.8.4
(com.media.feature.mwb.automator.feature.group 1.7.8.4)
To: com.media.mwb.automator [1.7.8.4]
Cannot satisfy dependency:
From: Inspector Cmd Bridge 1.0.4.1
(com.media.feature.mwb.inspectorcmdbridge.feature.group 1.0.4.1)
To: com.media.mwb.automator [1.7.8.3]
Previous Topic:product export wizard fails
Next Topic:(no subject)
Goto Forum:
  


Current Time: Sun Aug 31 06:38:56 EDT 2014

Powered by FUDForum. Page generated in 0.06785 seconds