Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » Problem running the LEG example?(A problem that occurred while trying the EclipseCon 2009 tutorial)
Problem running the LEG example? [message #698046] Mon, 18 July 2011 17:17 Go to next message
sultanikincikopru is currently offline sultanikincikopruFriend
Messages: 5
Registered: July 2011
Junior Member
Hello,

I have tried to create and run the LEG IDE example as presented in the EclipseCon2009 slides but after generating the AST and grammar files as specified in the tutorial PDF, I tried to run the IDE - as said in the Example 1c: Running your ide, I ran into a problem. When I try to select the plugins that will be run at the debug configurations menu, the workspace of the leg is said to be out of sync and I can't execute the IDE code in order to test the LEG language. The Eclipse version that I'm using has the following info; Version: Indigo Release (that is, 3.7) Build id: 20110615-0604. How can I solve this problem? Thanks in advance.
(no subject) [message #698199 is a reply to message #698046] Tue, 19 July 2011 00:54 Go to previous messageGo to next message
Robert M. Fuhrer is currently offline Robert M. FuhrerFriend
Messages: 294
Registered: July 2009
Senior Member
On 7/18/11 1:17 PM, forums-noreply@eclipse.org wrote:
> Hello,
> I have tried to create and run the LEG IDE example as presented in the EclipseCon2009 slides but after generating the
> AST and grammar files as specified in the tutorial PDF, I tried to run the IDE - as said in the Example 1c: Running your
> ide, I ran into a problem. When I try to select the plugins that will be run at the debug configurations menu, the
> workspace of the leg is said to be out of sync and I can't execute the IDE code in order to test the LEG language. The
> Eclipse version that I'm using has the following info; Version: Indigo Release (that is, 3.7) Build id: 20110615-0604.
> How can I solve this problem? Thanks in advance.

Is your launch configuration set up to use "all workspace and enabled target plugins",
or are you selecting individual plugins from the list? I have seen the error you've
pointed out, but I don't think it's actually prevented me from running.

That said, a quick googling turned up this entry in the Eclipse Plug-in Development
FAQ:


http://wiki.eclipse.org/Eclipse_Plug-in_Development_FAQ#A_plug-in_in_my_.27Eclipse_Application.27_launch_configuration_is_listed_as_being_.22out_of_sync.22.2C_what_should_I_do.3F

If that doesn't help, let me know, and I'll poke around a bit more.

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10-lang.org)
Re: (no subject) [message #698231 is a reply to message #698199] Tue, 19 July 2011 04:05 Go to previous message
sultanikincikopru is currently offline sultanikincikopruFriend
Messages: 5
Registered: July 2011
Junior Member
I am selecting individual plugins from the list according to the IMP User manual -dated May 2008- that is also present in the documentations you have provided. I couldn't find the folder org.eclipse.pde in the .metadata -there is one actually in .metadata/plugins but I don't know whether it is a typo and even deleting that didn't work.- I tried to debug the leg project but I couldn't create a LEG project along with .leg files, I could only create a simple project without .classpaths and stuff, and when I wrote into the editor -.leg files- all I got was error highlighting and syntax wasn't recognized properly.
Previous Topic:Using JavaCC with IMP?
Next Topic:SableCC Integration
Goto Forum:
  


Current Time: Sun Dec 21 13:33:15 GMT 2014

Powered by FUDForum. Page generated in 0.03037 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software