Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » SWT GroupLayout mssing
SWT GroupLayout mssing [message #698017] Mon, 18 July 2011 11:51 Go to next message
Ralf Ebert is currently offline Ralf Ebert
Messages: 72
Registered: July 2009
Member
Hi,

the GroupLayout is missing from the SWT Layout palette in my 3.7 install. Is this a bug or do I miss something there/is there something special I have to do to get support for the SWT GroupLayout?

I installed the SWT Designer + dependencies for Indigo features from http://download.eclipse.org/windowbuilder/WB/release/R201106211200/3.7/ :

SWT Designer 1.0.0.r37x201106091049
SWT Designer Core 1.0.0.r37x201106081643
SWT Designer Documentation 1.0.0.r37x201106081544

on top of Eclipse for RCP/RAP developers 3.7. I got the "WindowBuilder GroupLayout Support 1.0.0.r37x201106081642" as dependency.

Greetings,

Ralf
Re: SWT GroupLayout mssing [message #698111 is a reply to message #698017] Mon, 18 July 2011 15:44 Go to previous messageGo to next message
Eric Clayberg is currently offline Eric Clayberg
Messages: 856
Registered: July 2009
Location: Boston, MA
Senior Member
Because of Eclipse IP issues, SWT GroupLayout code is not included in any Eclipse.org releases.

The code is available in an Eclipse Labs project called "WindowBuilder Extras"...

http://svn.codespot.com/a/eclipselabs.org/windowbuilder-extras/trunk/

You can also get it in the WB build at code.google.com...

http://code.google.com/javadevtools/download-wbpro-beta.html
Re: SWT GroupLayout mssing [message #698115 is a reply to message #698111] Mon, 18 July 2011 15:51 Go to previous message
Ralf Ebert is currently offline Ralf Ebert
Messages: 72
Registered: July 2009
Member
Thanks! I was unsure if one is supposed to use the update site from dl.google.com or from eclipse.org - I went for the eclipse one because it featured a site explicitly for 3.7... Any plans to offer a p2 site for the windowbuilder-extras so that these could be easily installed on top of the eclipse.org WB feature?
Previous Topic:Error PropertyResolutionException
Next Topic:I get "Missing requirement" when updating
Goto Forum:
  


Current Time: Thu Aug 21 10:15:22 EDT 2014

Powered by FUDForum. Page generated in 0.06073 seconds