Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » Error Converting a Project to AspectJ
Error Converting a Project to AspectJ [message #70939] Wed, 05 December 2007 00:29 Go to next message
Eclipse User
Originally posted by: simaomm.gmail.com

Hi,

I am trying to convert a existing project to AspectJ using AJDT, and I get
the following error all over my code:

Syntax error, annotations are only available if source level is 5.0

Along with several other errors related to the jvm version in use.

Isn't AJDT compatible with java 1.6?

Thank you for your help,

Simão Mata
Re: Error Converting a Project to AspectJ [message #70959 is a reply to message #70939] Wed, 05 December 2007 08:22 Go to previous message
Mickael GAUVIN is currently offline Mickael GAUVIN
Messages: 38
Registered: July 2009
Member
Hi Simao Mata,

AJDT for java 1.6 is not ready yet.
You must use java 1.5 and AspectJ 1.5.x and wait for AspectJ 1.6.

Regards.

Simao Mata a écrit :
> Hi,
>
> I am trying to convert a existing project to AspectJ using AJDT, and I
> get the following error all over my code:
>
> Syntax error, annotations are only available if source level is 5.0
>
> Along with several other errors related to the jvm version in use.
>
> Isn't AJDT compatible with java 1.6?
>
> Thank you for your help,
>
> Simão Mata
>
>
>
>
Re: Error Converting a Project to AspectJ [message #596548 is a reply to message #70939] Wed, 05 December 2007 08:22 Go to previous message
Mickael GAUVIN is currently offline Mickael GAUVIN
Messages: 38
Registered: July 2009
Member
Hi Simao Mata,

AJDT for java 1.6 is not ready yet.
You must use java 1.5 and AspectJ 1.5.x and wait for AspectJ 1.6.

Regards.

Simao Mata a écrit :
> Hi,
>
> I am trying to convert a existing project to AspectJ using AJDT, and I
> get the following error all over my code:
>
> Syntax error, annotations are only available if source level is 5.0
>
> Along with several other errors related to the jvm version in use.
>
> Isn't AJDT compatible with java 1.6?
>
> Thank you for your help,
>
> Simão Mata
>
>
>
>
Previous Topic:Error Converting a Project to AspectJ
Next Topic:AJDT with Eclipse 3.4M3 64-bit
Goto Forum:
  


Current Time: Sat Sep 20 06:07:34 GMT 2014

Powered by FUDForum. Page generated in 0.07562 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software