Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EEF] No EEF component & view element created Single Valued Containment References
[EEF] No EEF component & view element created Single Valued Containment References [message #696611] Thu, 14 July 2011 11:58 Go to next message
Nidhi  is currently offline Nidhi Friend
Messages: 92
Registered: December 2009
Member

Hi,

I am using EEF to generate the UI corresponding to my ecore metamodel. However, for any single valued containment reference, there is no "Properties Edition Element" in the component as well as "Elememt Editor" created in the view. However, for multivalued containment references this is created.

It would be really helpful to get some pointers.

Thanks a lot in advance,
Best Regards,
Nidhi
Re: [EEF] No EEF component & view element created Single Valued Containment References [message #696796 is a reply to message #696611] Thu, 14 July 2011 19:48 Go to previous message
Goulwen Le Fur is currently offline Goulwen Le FurFriend
Messages: 125
Registered: July 2009
Senior Member
Hi Nidhi, you're right for the moment no PropertiesEditionElement (or
ElementEditor) is created for the case single valued containment
reference. You can manually create a ElementEditor with a
AdvancedEObjectFlatComboViewer as representation and a
PropertiesEditionElement binding your reference and the newly created
ElementEditor.

Regards.

--
Goulwen Le Fur - goulwen.lefur@obeo.fr

Le 14/07/2011 13:58, Nidhi a écrit :
> Hi,
>
> I am using EEF to generate the UI corresponding to my ecore metamodel.
> However, for any single valued containment reference, there is no
> "Properties Edition Element" in the component as well as "Elememt
> Editor" created in the view. However, for multivalued containment
> references this is created.
>
> It would be really helpful to get some pointers.
>
> Thanks a lot in advance,
> Best Regards,
> Nidhi
Previous Topic:how to add ecore tools to eclipse
Next Topic:[Texo/Hibernate] Can I specify a different name for database table name?
Goto Forum:
  


Current Time: Sat Dec 20 18:39:04 GMT 2014

Powered by FUDForum. Page generated in 0.01710 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software