Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] getValue on ATL Map returns OclUndefined
[ATL] getValue on ATL Map returns OclUndefined [message #694135] Thu, 07 July 2011 21:47
Philipp Zech is currently offline Philipp Zech
Messages: 96
Registered: July 2009
Member
Hi,

in one of my transformations I currently make use of an ATL specific
map, storing static transformation related information, i.e.:

helper def : MAP : Map(UML!EnumLiteral, String) =
Map{
(#Literal1, 'sampleString1'),
(#Literal2, 'sampleString2')
};

so far the definition of the map and also referencing it works
seamlessly, however, whenever trying to retrieve a stored value from the
map by using the get() operation (from inside another helper), i.e.:

thisModule.MAP.get(#Literal1)

simply an object of type OclUndefined is returned, yet no exception or
anything else is thrown. So my question now is, why doesn't get()
actually return an object of type String, but instead returns an object
of type OclUndefined, although the declaration of the map clearly states
that it contains String objects? Am I missing something?

Thanks a lot for any help!

Cheers,

Philipp
Previous Topic:[ATL] Profile and Stereotype Application in Target Model
Next Topic:[ATL] getValue on ATL Map returns OclUndefined
Goto Forum:
  


Current Time: Thu Oct 23 03:13:01 GMT 2014

Powered by FUDForum. Page generated in 0.14426 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software