Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » osgi console problem
osgi console problem [message #693314] Wed, 06 July 2011 08:53 Go to next message
Vladimir Stevanovic is currently offline Vladimir Stevanovic
Messages: 29
Registered: March 2010
Junior Member
I'm not sure how osgi console is organized in virgo - are there two consoles for kernel and user regions, or there is only one common console?
I've tried to put configuration osgi.console=... in org.eclipse.virgo.kernel.launch.properties and in org.eclipse.virgo.kernel.userregion.properties. Of course, I set two different ports. Only the console from the first file is opened.

And by successively executing "ss" command, the output is different: it looks like that first executions displays only user bundles, the second shows kernerl bundles, the third again user bundles...

I'm using the latest, M6 version of Virgo.

Also, vsh command generates two different outputs - one blank, and the other : "gogo: CommandNotFoundException: Command not found: vsh"



Re: osgi console problem [message #693315 is a reply to message #693314] Wed, 06 July 2011 08:56 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
The console support is configured completely differently in M06 compared to M05. The release notes describe the new configuration in some detail, since we haven't yet updated the User Guide.
Re: osgi console problem [message #693335 is a reply to message #693315] Wed, 06 July 2011 09:29 Go to previous messageGo to next message
Vladimir Stevanovic is currently offline Vladimir Stevanovic
Messages: 29
Registered: March 2010
Junior Member
Thanks. I read the release notes and accesses both shells.
Re: osgi console problem [message #722671 is a reply to message #693335] Tue, 06 September 2011 13:13 Go to previous messageGo to next message
Anthony MULLER is currently offline Anthony MULLER
Messages: 3
Registered: July 2009
Junior Member
I wonder how to execute commands explained in user guide using the new shell?

Regards,
Anthony
Re: osgi console problem [message #723231 is a reply to message #722671] Thu, 08 September 2011 06:21 Go to previous message
Violeta Georgieva is currently offline Violeta Georgieva
Messages: 242
Registered: October 2010
Senior Member
Hi,

Which commands do you mean?
Here you can find more about new shell http://eclipse.org/equinox/incubator/console/user-doc.php

Regards
Violeta
Previous Topic:"jmxPermissions.vbs(23, 2) SWbemServicesEx: Not found"
Next Topic:birt.war does not run properly
Goto Forum:
  


Current Time: Tue Oct 21 07:07:55 GMT 2014

Powered by FUDForum. Page generated in 0.02534 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software