Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Is there a "normal" p2 IU for a product in a repository
Is there a "normal" p2 IU for a product in a repository [message #692826] Tue, 05 July 2011 10:02 Go to next message
Mickael Istria is currently offline Mickael Istria
Messages: 765
Registered: July 2009
Location: Grenoble, France
Senior Member
Hi all,

I'd like to add an explicit dependency to my product for my test
execution with Tycho. Howerver, I did not find any installation unit
that installs me the whole product.
Is there an installation unit for a product that I could consume with Tycho?


Here is what I currently do, it is a re-definition of the content of my
product in the pom,xml:
<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-surefire-plugin</artifactId>
<version>${tycho-version}</version>
<configuration>
<argLine>-Xms64m -Xmx1024m -XX:MaxPermSize=128M</argLine>
<useUIHarness>true</useUIHarness>
<useUIThread>false</useUIThread>
<product>com.ebmwebsourcing.petals.studio.product</product>
<application>org.eclipse.ui.ide.workbench</application>
<dependencies>
<dependency>
<type>p2-installable-unit</type>
<artifactId>
com.ebmwebsourcing.petals.studio.rcp.feature.feature.group
</artifactId>
<version>0.0.0</version>
</dependency>
<dependency>
<type>p2-installable-unit</type>
<artifactId>
com.ebmwebsourcing.petals.studio.sca.feature.feature.group
</artifactId>
<version>0.0.0</version>
</dependency>
<dependency>
<type>p2-installable-unit</type>
<artifactId>
com.ebmwebsourcing.petals.studio.bpel.feature.feature.group
</artifactId>
<version>0.0.0</version>
</dependency>
<dependency>
<type>p2-installable-unit</type>
<artifactId>
com.ebmwebsourcing.petals.studio.core.feature.feature.group
</artifactId>
<version>0.0.0</version>
</dependency>
</dependencies>
<configuration>
</plugin>
</plugins>
</build>

And I'd like to replace all the <dependencies.../> block by something like:
<dependencies>
<dependency>
<type>p2-installable-unit</type>
<artifactId>com.ebmwebsourcing.petals.studio.product
</artifactId>
<version>0.0.0</version>
</dependency>
</dependencies>

I gave some unseccessful tries. Is there a way to consume directly a
product with p2, that I could leverage in Tycho?

Regards
Re: Is there a &quot;normal&quot; p2 IU for a product in a repository [message #698878 is a reply to message #692826] Wed, 20 July 2011 12:17 Go to previous message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

If you are doing a product build, PDE build will create a IU in your repo with the product ID as spec'ed in your .product file. That's the ID that can be used to instantiate a product with the director. Ex, our .product file:

<product name="Eclipse SDK" id="org.eclipse.sdk.ide" application="org.eclipse.ui.ide.workbench" version="4.1.0.I20110719-2201" useFeatures="true" includeLaunchers="true">
....
</product>



When I build my product, I can do:

$INSTALLER_HOME/eclipse \
-application org.eclipse.equinox.p2.director \
-noSplash \
-repository \
$BUILD_DIR/repository \
-installIU org.eclipse.sdk.ide \
-destination $BUILD_DIR/eclipse \
-bundlepool $BUILD_DIR/eclipse \
-profile SDKProfile \
-profileProperties org.eclipse.update.install.features=true \
-p2.os linux \
-p2.ws gtk \
-p2.arch x86_64 \
-roaming


To make sure your IU is there, you can use:

$INSTALLER_HOME/eclipse \
-application org.eclipse.equinox.p2.director \
-noSplash \
-repository \
$BUILD_DIR/repository \
-list


Later,
PW


Previous Topic:p2 director problems without running the target application
Next Topic:Help for an Eclipse project update site
Goto Forum:
  


Current Time: Mon Oct 20 23:00:36 GMT 2014

Powered by FUDForum. Page generated in 0.01597 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software