Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » install e4 tools failed on 4.1
install e4 tools failed on 4.1 [message #692653] Tue, 05 July 2011 00:04 Go to next message
autohandle  is currently offline autohandle
Messages: 2
Registered: July 2011
Junior Member
i am following the "An Introduction to e4 - how to write an RCP-Application with e4"

using the repository:
e4 0.11 Repository - http:\\download.eclipse.org/e4/updates/0.11

i selected:
Eclipse e4 Tools (Incubation) 0.10.0.v20110613-2030-28F1EVVFNMFz-Mh8XF_D

and i got the following message:

Cannot complete the install because one or more required items could not be found.
Software being installed: Eclipse e4 Tools (Incubation) 0.10.0.v20110613-2030-28F1EVVFNMFz-Mh8XF_D (org.eclipse.e4.core.tools.feature.feature.group 0.10.0.v20110613-2030-28F1EVVFNMFz-Mh8XF_D)
Missing requirement: EMF ModelTooling UI 0.10.0.v20110613-2030 (org.eclipse.e4.tools.emf.ui 0.10.0.v20110613-2030) requires 'bundle org.eclipse.emf.databinding.edit 1.2.0' but it could not be found
Cannot satisfy dependency:
From: Eclipse e4 Tools (Incubation) 0.10.0.v20110613-2030-28F1EVVFNMFz-Mh8XF_D (org.eclipse.e4.core.tools.feature.feature.group 0.10.0.v20110613-2030-28F1EVVFNMFz-Mh8XF_D)
To: org.eclipse.e4.tools.emf.ui [0.10.0.v20110613-2030]

the other repositories are not being found:
Error
Mon Jul 04 16:57:37 PDT 2011
No repository found at http:\\download.eclipse.org/e4/downloads/updates/2010.
Error
Mon Jul 04 16:57:37 PDT 2011
No repository found at http:\\download.eclipse.org/e4/downloads/updates/2011.
Error
Mon Jul 04 16:57:37 PDT 2011
No repository found at http:\\download.eclipse.org/e4/downloads/updates.
Re: install e4 tools failed on 4.1 [message #698428 is a reply to message #692653] Tue, 19 July 2011 13:07 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

The correct update site for 0.11 is http://download.eclipse.org/e4/updates/0.11

You also have to have EMF installed (I usually install the EMF SDK) from http://download.eclipse.org/releases/indigo

PW


Re: install e4 tools failed on 4.1 [message #787371 is a reply to message #698428] Tue, 31 January 2012 14:08 Go to previous messageGo to next message
Lars Vogel is currently offline Lars Vogel
Messages: 1049
Registered: July 2009
Senior Member

See Eclipse 4 Application Development for the installation of the latest and greatest Eclipse 4.2 version.
Re: install e4 tools failed on 4.1 [message #895524 is a reply to message #787371] Fri, 13 July 2012 11:27 Go to previous message
Gregor Rosenauer is currently offline Gregor Rosenauer
Messages: 4
Registered: July 2009
Junior Member
Ok still got this error but solved it (see below):
Quote:
Cannot complete the install because one or more required items could not be found.
Software being installed: Eclipse e4 Tools (Incubation) 0.12.0.v20120529-2033-28Q1EVVFNTFtSK8WOZd51 (org.eclipse.e4.core.tools.feature.feature.group 0.12.0.v20120529-2033-28Q1EVVFNTFtSK8WOZd51)
Missing requirement: Editor3x 0.12.0.v20120529-2033 (org.eclipse.e4.tools.emf.editor3x 0.12.0.v20120529-2033) requires 'bundle org.eclipse.emf.edit 2.6.0' but it could not be found
Cannot satisfy dependency:
From: Eclipse e4 Tools (Incubation) 0.12.0.v20120529-2033-28Q1EVVFNTFtSK8WOZd51 (org.eclipse.e4.core.tools.feature.feature.group 0.12.0.v20120529-2033-28Q1EVVFNTFtSK8WOZd51)
To: org.eclipse.e4.tools.emf.editor3x [0.12.0.v20120529-2033]

The link on Thomas' excellent tutorial site has changed to:
www.vogella.com/articles/EclipseRCP/article.html#tutorial_installation2

If you - like me - have installed your package manager's Eclipse version in Linux, you have to install Eclipse RCP SDK from the general 4.2 update site:
http://download.eclipse.org/eclipse/updates/4.2

and the needed EMF dependency from the Juno update site at:
http://download.eclipse.org/releases/junoe:

update site URLs taken from the official wiki:
http://wiki.eclipse.org/Eclipse_Project_Update_Sites

After that, you can install the e4 tools from the link Thomas mentioned.
Previous Topic:Getting rid of CSS theme
Next Topic:Programmatically detach a view
Goto Forum:
  


Current Time: Tue Sep 16 04:55:47 GMT 2014

Powered by FUDForum. Page generated in 0.11289 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software