Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Birt Viewer 3.7 does not work with Internet Explorer 8
Birt Viewer 3.7 does not work with Internet Explorer 8 [message #692467] Mon, 04 July 2011 13:49 Go to next message
Marcos  is currently offline Marcos Friend
Messages: 5
Registered: July 2011
Junior Member
We've upgraded our Birt installation from 2.3.2 to 2.6.2 and then 3.7 recently, along with a switch from Windows / Tomcat 5.5 to Linux / Tomcat 6. Everything is working fine, except that reports do not render within Internet Explorer 8 (7 is fine). The following error messages are shown in the browser:

Line: 159
Character: 3
Code: 0
Error Message: Invalid argument
URL: .../birt/webcontent/birt/ajax/ui/report/AbstractBaseReportDocument.js

Line: 1818
Character: 4
Code: 0
Error Message: 'birtParameterDialog' is null or is not an object
URL: .../birt/frameset?__report=problem_report.rptdesign

I've tried debugging in IE to find out what's wrong but I could not come to any explanation. Even though most of our users have Firefox, it would be nice if the tool could still be compatible with IE. Interestingly, only the frameset option causes this problem - using the preview or run options, the report works fine with IE 8.

Has anyone faced a similar problem ? I've tried changing some of the IE settings (like adding the site to the trusted sites list) but that didn't bring any results.

Any tips will be greatly appreciated !
Re: Birt Viewer 3.7 does not work with Internet Explorer 8 [message #692947 is a reply to message #692467] Tue, 05 July 2011 14:06 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Marcos,

I am running 3.7 in IE 8 and it is working. What security options are
you using?

Jason

On 7/4/2011 9:49 AM, Marcos wrote:
> We've upgraded our Birt installation from 2.3.2 to 2.6.2 and then 3.7
> recently, along with a switch from Windows / Tomcat 5.5 to Linux /
> Tomcat 6. Everything is working fine, except that reports do not render
> within Internet Explorer 8 (7 is fine). The following error messages are
> shown in the browser:
>
> Line: 159
> Character: 3
> Code: 0
> Error Message: Invalid argument
> URL: .../birt/webcontent/birt/ajax/ui/report/AbstractBaseReportDocument.js
>
> Line: 1818
> Character: 4
> Code: 0
> Error Message: 'birtParameterDialog' is null or is not an object
> URL: .../birt/frameset?__report=problem_report.rptdesign
>
> I've tried debugging in IE to find out what's wrong but I could not come
> to any explanation. Even though most of our users have Firefox, it would
> be nice if the tool could still be compatible with IE. Interestingly,
> only the frameset option causes this problem - using the preview or run
> options, the report works fine with IE 8.
>
> Has anyone faced a similar problem ? I've tried changing some of the IE
> settings (like adding the site to the trusted sites list) but that
> didn't bring any results.
>
> Any tips will be greatly appreciated !
Re: Birt Viewer 3.7 does not work with Internet Explorer 8 [message #692956 is a reply to message #692947] Tue, 05 July 2011 14:40 Go to previous messageGo to next message
Marcos  is currently offline Marcos Friend
Messages: 5
Registered: July 2011
Junior Member
Well, you've just given me an idea and it worked: I've added the Birt web site to the list of intranet sites. As it seems, adding it to the trusted sites list was not enough.

Thanks for the tip !

Marcos
Re: Birt Viewer 3.7 does not work with Internet Explorer 8 [message #692989 is a reply to message #692956] Tue, 05 July 2011 14:49 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Marcos,

Thanks for the update.

Jason

On 7/5/2011 10:40 AM, Marcos wrote:
> Well, you've just given me an idea and it worked: I've added the Birt
> web site to the list of intranet sites. As it seems, adding it to the
> trusted sites list was not enough.
>
> Thanks for the tip !
>
> Marcos
Previous Topic:Report parameters
Next Topic:Visibility: hide cross tab when null cube
Goto Forum:
  


Current Time: Wed Nov 26 23:40:39 GMT 2014

Powered by FUDForum. Page generated in 0.02663 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software