Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » [Embedded Birt] : Migration to 3.7(required libraries ?)
[Embedded Birt] : Migration to 3.7 [message #690269] Wed, 29 June 2011 09:53 Go to next message
miaou  is currently offline miaou
Messages: 4
Registered: June 2011
Junior Member
Hi everybody,
I plan to migrate to Birt 3.7 version.
We have embedded Birt engine into our application as many of you have done.

According to the wiki migration page (htp://wiki.eclipse.org/Birt_3.7_Migration_Guide), external runtime is no more necessary,
nor the following code :
config.setBIRTHome("pathtoruntime");

Only add all ReportEngine/lib jars to application classpath (WEB-INF/lib for example) is required.

Comparing Birt 2.6.2 to 3.7 version, I note that there are many more libraries (24 vs 78).

I can guess that some of them are optional, but is there any documentation about library requirement and feature ?

The aim is :

  • I want to avoid as much as possible library conflict.
  • As Birt libraries are still not publish on any maven repository, I would like to create my own maven descriptor file and publish Birt libraries on my local maven proxy.


Thanks you for any help.
Best Regards,
Nicolas
Re: [Embedded Birt] : Migration to 3.7 [message #690452 is a reply to message #690269] Wed, 29 June 2011 14:29 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Nicolas

There are more libs because the runtime jars are no longer in the
platform/plugins directory. All the birt functionality is one jar. The
only jars that I see that could be trimmed are the datatools jars, which
have jars for different data source types. You could also remove
derby.jar if you do not want to use the sample db.

Jason

On 6/29/2011 5:53 AM, miaou wrote:
> Hi everybody,
> I plan to migrate to Birt 3.7 version.
> We have embedded Birt engine into our application as many of you have done.
>
> According to the wiki migration page
> (htp://wiki.eclipse.org/Birt_3.7_Migration_Guide), external runtime is
> no more necessary, nor the following code :
> config.setBIRTHome("pathtoruntime");
> Only add all ReportEngine/lib jars to application classpath (WEB-INF/lib
> for example) is required.
>
> Comparing Birt 2.6.2 to 3.7 version, I note that there are many more
> libraries (24 vs 78).
>
> I can guess that some of them are optional, but is there any
> documentation about library requirement and feature ?
>
> The aim is :
> I want to avoid as much as possible library conflict.
> As Birt libraries are still not publish on any maven repository, I would
> like to create my own maven descriptor file and publish Birt libraries
> on my local maven proxy.
>
>
> Thanks you for any help.
> Best Regards,
> Nicolas
Re: [Embedded Birt] : Migration to 3.7 [message #690488 is a reply to message #690452] Wed, 29 June 2011 15:22 Go to previous messageGo to next message
miaou  is currently offline miaou
Messages: 4
Registered: June 2011
Junior Member
Hi Jason,
thanks for your answer.

I will add commons-cli to the list you provided.

Do you think that all batik libraries are needed ? Aren't they used only for svg generation ? (a feature I don't use, I think)

Nicolas
Re: [Embedded Birt] : Migration to 3.7 [message #690516 is a reply to message #690488] Wed, 29 June 2011 15:53 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Nicolas

The batik libraries are used heavily when converting a chart (that is
set to svg format) to pdf etc. I believe they are also used in
processing some inline styles with pdf. I will need to check.

Jason

On 6/29/2011 11:22 AM, miaou wrote:
> Hi Jason,
> thanks for your answer.
>
> I will add commons-cli to the list you provided.
>
> Do you think that all batik libraries are needed ? Aren't they used only
> for svg generation ? (a feature I don't use, I think)
>
> Nicolas
Re: [Embedded Birt] : Migration to 3.7 [message #690524 is a reply to message #690516] Wed, 29 June 2011 16:22 Go to previous messageGo to next message
miaou  is currently offline miaou
Messages: 4
Registered: June 2011
Junior Member
mmmh, do not check Jason
as I (sometimes) used chart into my reports,
so I need to keep them too.

Once again, thx for your reply !!

Nicolas
Re: [Embedded Birt] : Migration to 3.7 [message #690558 is a reply to message #690524] Wed, 29 June 2011 16:55 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Nicolas,

I think Scott Rosenbaum may be setting up a maven server at his site.
He will post on birtworld.blogspot.com if he does. If you set one up
please let me know.

Jason

On 6/29/2011 12:22 PM, miaou wrote:
> mmmh, do not check Jason
> as I (sometimes) used chart into my reports,
> so I need to keep them too.
>
> Once again, thx for your reply !!
>
> Nicolas
>
Re: [Embedded Birt] : Migration to 3.7 [message #762649 is a reply to message #690269] Thu, 08 December 2011 12:58 Go to previous messageGo to next message
Christofer Dutz is currently offline Christofer Dutz
Messages: 1
Registered: December 2011
Junior Member
Hi,

I was struggling with embeding the Birt Runtime 3.7.1 into my application for several days now. Finally I managed to get it running. I documented everything im my Wiki. ://dev.c-ware.de/confluence/display/PUBLIC/Embeding+Birt+into+Application+built+with+Maven

Just add "https" to the beginning of that url (My first post ... have to do 4 more posts in order to post links) Wink

I thought I'd just leave a note here as this was one of the threads I initially looked into when starting the integration.

Hope it helps someone,
Chris
Re: [Embedded Birt] : Migration to 3.7 [message #777055 is a reply to message #762649] Mon, 09 January 2012 18:38 Go to previous messageGo to next message
John Okrasa is currently offline John Okrasa
Messages: 2
Registered: January 2012
Junior Member
I'm looking for the Maven Dependencies (POM.xml) I could use for the attached image of jars I would use in my report.

So jar I just can't find something that would work.

I get a generic error ( which doesn't tell me which dependency to look for ,... unless it is in fact the pdf emitter I would need).

Thanks for all your help!

John.

index.php/fa/6678/0/
Re: [Embedded Birt] : Migration to 3.7 [message #777070 is a reply to message #777055] Mon, 09 January 2012 19:40 Go to previous messageGo to next message
John Okrasa is currently offline John Okrasa
Messages: 2
Registered: January 2012
Junior Member
Actually I just need to be able to find the Maven dependency that holds the :

org.eclipse.birt.runtime_3.7.0. ... jar

for some reason I can't find it !
Re: [Embedded Birt] : Migration to 3.7 [message #777158 is a reply to message #777070] Tue, 10 January 2012 00:24 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Have you seen this thread?
http://www.birt-exchange.org/org/forum/index.php/topic/24196-mavenizing-birt-3-7-1/page__s__7cade7bfb41b8a4df793393e6db16d75

Jason

On 1/9/2012 2:40 PM, John Okrasa wrote:
> Actually I just need to be able to find the Maven dependency that holds
> the :
>
> org.eclipse.birt.runtime_3.7.0. ... jar
>
> for some reason I can't find it !
Previous Topic:Reg: rptdesign files getting corrupted
Next Topic:How to set the report version property ?
Goto Forum:
  


Current Time: Thu Oct 23 00:55:01 GMT 2014

Powered by FUDForum. Page generated in 0.12151 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software