Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » NullPointerException when connecting to http://localhost/TutorialMiniCrm/process
NullPointerException when connecting to http://localhost/TutorialMiniCrm/process [message #689713] Tue, 28 June 2011 08:29 Go to next message
Christian Eugster is currently offline Christian Eugster
Messages: 134
Registered: July 2009
Location: St. Gallen Switzerland
Senior Member
Hi, I am absolutely new to scout. I read the tutorials, consumed to webinar and read the documentation as far. Because this project seems to be interesting I installed to minicrm tutorial. After started the server, I try to connect via the browser. While connecting there is a npe thrown:

HTTP ERROR 500

Problem accessing /TutorialMiniCrm/process. Reason:

INTERNAL_SERVER_ERROR

Caused by:

java.lang.NullPointerException
at org.eclipse.scout.rt.shared.services.common.security.ACCESS.check(Unknown Source)
at org.eclipse.scout.rt.server.admin.html.view.ServicesView.isVisible(Unknown Source)
at org.eclipse.scout.rt.server.admin.html.view.TopView.produceBody(Unknown Source)
at org.eclipse.scout.rt.server.admin.html.AdminSession.serviceRequest(Unknown Source)
at org.eclipse.scout.rt.server.ServiceTunnelServlet.doGet(Unknown Source)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.eclipse.scout.http.servletfilter.HttpServletEx.access$0(Unknown Source)
at org.eclipse.scout.http.servletfilter.HttpServletEx$1.service(Unknown Source)
at org.eclipse.scout.http.servletfilter.internal.FilterChainImpl.doFilter(Unknown Source)
at org.eclipse.scout.rt.server.servlet.filter.AbstractChainableSecurityFilter.doFilterInternal(Unknown Source)
at org.eclipse.scout.rt.server.servlet.filter.AbstractChainableSecurityFilter.access$0(Unknown Source)
at org.eclipse.scout.rt.server.servlet.filter.AbstractChainableSecurityFilter$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at javax.security.auth.Subject.doAs(Unknown Source)
at org.eclipse.scout.rt.server.servlet.filter.AbstractChainableSecurityFilter.doFilter(Unknown Source)
at org.eclipse.scout.http.servletfilter.internal.FilterChainImpl.doFilter(Unknown Source)
at org.eclipse.scout.http.servletfilter.ServletFilterDelegate.delegateServiceMethod(Unknown Source)
at org.eclipse.scout.http.servletfilter.HttpServletEx.service(Unknown Source)
at org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:180)
at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(ServletRegistration.java:61)
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:126)
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:60)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.eclipse.equinox.http.jetty.internal.HttpServerManager$InternalHttpServiceServlet.service(HttpServerManager.java:317)
at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:390)
at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765)
at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
at org.mortbay.jetty.Server.handle(Server.java:326)
at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)
at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:924)
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:549)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409)
at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)

Powered by Jetty://

What am I doing wrong?

Thank you!
Re: NullPointerException when connecting to http://localhost/TutorialMiniCrm/process [message #689967 is a reply to message #689713] Tue, 28 June 2011 16:45 Go to previous message
Daniel Wiehl is currently offline Daniel Wiehl
Messages: 24
Registered: April 2010
Junior Member
Hi Christian
We solved the problem for release 3.7.1 (SR1) on 9/23/2011.
We created a bug on bugzilla you can track at https://bugs.eclipse.org/bugs/show_bug.cgi?id=350606. Please have a look at the proposed workaround on the bug's description until SR1 is published.

If you have any further questions, please let me know.

[Updated on: Wed, 29 June 2011 07:31]

Report message to a moderator

Previous Topic:WebStart with Scout
Next Topic:AbstractTable: Dynamic Columns
Goto Forum:
  


Current Time: Tue Oct 21 02:29:51 GMT 2014

Powered by FUDForum. Page generated in 0.01500 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software