Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Dependency Injection - JSR-299?
Dependency Injection - JSR-299? [message #689327] Mon, 27 June 2011 13:00 Go to next message
Ralf Zahn is currently offline Ralf ZahnFriend
Messages: 32
Registered: July 2009
Member
Hi,

Eclipse 4.x uses annotations for dependency injection and lifecycle management. But it does not implement JSR-299 (CDI), right?
Wouldn't it be great to use CDI for Eclipse 4.x? (This would allow single sourcing of components running in both Eclipse and Apache Aries with Java EE6 environments.)
Re: Dependency Injection - JSR-299? [message #1712858 is a reply to message #689327] Wed, 28 October 2015 20:14 Go to previous messageGo to next message
Frank Benoit is currently offline Frank BenoitFriend
Messages: 108
Registered: July 2009
Senior Member
I would be interested in reading an answer Smile

Re: Dependency Injection - JSR-299? [message #1712864 is a reply to message #1712858] Wed, 28 October 2015 21:56 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6264
Registered: July 2009
Senior Member
No we are not CDI compliant and IMHO the useage of @PostConstruct and
@PreDestroy have been the biggest mistake we made in Eclipse 4 DI.

We are JSR 330 compliant only!

Tom

On 28.10.15 13:14, Frank Benoit wrote:
> I would be interested in reading an answer :)
>
>
Previous Topic:Callback for EventLoopException
Next Topic:child windows in e4 rcp application
Goto Forum:
  


Current Time: Mon Dec 05 10:37:05 GMT 2016

Powered by FUDForum. Page generated in 0.20065 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software