Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Example for new user(Need Helios PHP setup instructions and download)
Example for new user [message #688582] Fri, 24 June 2011 21:01 Go to next message
Robert  is currently offline Robert
Messages: 14
Registered: September 2010
Junior Member
I am building my first ever PHP project in eclipse. I have Helios platform 3.6
Everyone seems to rave/recommend PDT BUT I dont want to mess up my Eclipse install by upgrading the IDE with a bundle. I already have a lot of stuff added to the IDE so I just want to add in the PDT. The PDT site seemed to contain no "just PDT" download. It there a stable build http url I can add to my ide for download/updates?


Also how does this integrate to PHP and is it OK to run PHP/PDT/Eclipse with a Tomcat web server? Again I see examples and such hither and yon but none is my exact case and it seems that most people setup for Apache rather than Tomcat. I am new to all of this so I am having trouble getting things setup for integration. Can someone point me to an example of PHP/PDT/Tomcat/Eclipse? I am also using MySQL database.

Any help is greatly appreciated.

Re: Example for new user [message #689368 is a reply to message #688582] Mon, 27 June 2011 10:11 Go to previous messageGo to next message
Robert  is currently offline Robert
Messages: 14
Registered: September 2010
Junior Member
I still havent found a way to add PDT to eclipse.

All the builds are bundled. I tried the following:

1) Just use the bundle! OK then I dont get all my J2ee stuff and it doesnt seem to add right when I try to.
2) Start with J2ee eclipse and install pdt as new software - update site for PDT http://download.eclipse.org/tools/pdt/updates/site.xml fails I get:

Cannot complete the install because of a conflicting dependency.
Software being installed: PDT SDK Feature 1.0.5.v20081126-1856 (org.eclipse.php.sdk_feature.feature.group 1.0.5.v20081126-1856)
Software currently installed: Eclipse IDE for Java EE Developers 1.3.2.20110218-0812 (epp.package.jee 1.3.2.20110218-0812)
Only one of the following can be installed at once:
International Components for Unicode for Java (ICU4J) 3.8.1.v20080530 (com.ibm.icu 3.8.1.v20080530)
International Components for Unicode for Java (ICU4J) 4.2.1.v20100412 (com.ibm.icu 4.2.1.v20100412)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.3.2.20110218-0812 (epp.package.jee 1.3.2.20110218-0812)
To: org.eclipse.epp.package.jee.feature.feature.group [1.3.2.20110218-0812]
Cannot satisfy dependency:
From: Java EE IDE Feature 1.3.2.20110218-0812 (org.eclipse.epp.package.jee.feature.feature.group 1.3.2.20110218-0812)
To: org.eclipse.platform.feature.group [3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi]
Cannot satisfy dependency:
From: PDT SDK Feature 1.0.5.v20081126-1856 (org.eclipse.php.sdk_feature.feature.group 1.0.5.v20081126-1856)
To: org.eclipse.php_feature.feature.group [1.0.5.v20081126-1856]
Cannot satisfy dependency:
From: PDT Feature 1.0.5.v20081126-1856 (org.eclipse.php_feature.feature.group 1.0.5.v20081126-1856)
To: org.eclipse.wst.feature.group [3.0.0,4.0.0)
Cannot satisfy dependency:
From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)
To: org.eclipse.rcp.feature.group [3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY]
Cannot satisfy dependency:
From: Eclipse RCP 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY (org.eclipse.rcp.feature.group 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY)
To: com.ibm.icu [4.2.1.v20100412]
Cannot satisfy dependency:
From: SSE CSS Source Editor 1.0.301.v200807170605 (org.eclipse.wst.css.ui 1.0.301.v200807170605)
To: bundle com.ibm.icu [3.8.1,4.0.0)
Cannot satisfy dependency:
From: Web Developer Tools 3.0.4.v200811190840-7A-8l8Qqcz0HyVgjXUE-iuOYZ9ai (org.eclipse.wst.feature.group 3.0.4.v200811190840-7A-8l8Qqcz0HyVgjXUE-iuOYZ9ai)
To: org.eclipse.wst.web_ui.feature.feature.group [3.0.4.v200811240900-7R0EP7E8Ks9v7urtuDJtBcaRV6Ri]
Cannot satisfy dependency:
From: WST Web UI 3.0.4.v200811240900-7R0EP7E8Ks9v7urtuDJtBcaRV6Ri (org.eclipse.wst.web_ui.feature.feature.group 3.0.4.v200811240900-7R0EP7E8Ks9v7urtuDJtBcaRV6Ri)
To: org.eclipse.wst.css.ui [1.0.301.v200807170605]

I confess I have very little idea what is happening. It seems the thing needs me to delete one of those unicode features.

Can someone get me through this or suggest another approach?

[Updated on: Mon, 27 June 2011 10:13]

Report message to a moderator

Re: Example for new user [message #689370 is a reply to message #689368] Mon, 27 June 2011 10:18 Go to previous message
Robert  is currently offline Robert
Messages: 14
Registered: September 2010
Junior Member
I also tried the update site http://download.eclipse.org/tools/pdt/updates/3.0/milestones/
found in another recnt post as a suggestion for PDT for someone else. It failed also with:

Cannot complete the install because one or more required items could not be found.
Software being installed: PHP Development Tools (PDT) SDK Feature 3.0.0.v20110516-1100-77--84_23JBVgSVXO7XGJz0VLa9O (org.eclipse.php.sdk.feature.group 3.0.0.v20110516-1100-77--84_23JBVgSVXO7XGJz0VLa9O)
Missing requirement: PHP Development Tools (PDT) Runtime Feature 3.0.0.v20110516-1100-7V--F8NcJTTK4UE9TTJJ (org.eclipse.php.feature.group 3.0.0.v20110516-1100-7V--F8NcJTTK4UE9TTJJ) requires 'org.eclipse.dltk.core.index.feature.group [3.0.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: PHP Development Tools (PDT) SDK Feature 3.0.0.v20110516-1100-77--84_23JBVgSVXO7XGJz0VLa9O (org.eclipse.php.sdk.feature.group 3.0.0.v20110516-1100-77--84_23JBVgSVXO7XGJz0VLa9O)
To: org.eclipse.php.feature.group [3.0.0.v20110516-1100-7V--F8NcJTTK4UE9TTJJ]

So I think that is just an update and not the base PDT which makes sense. grrr ....

[Updated on: Mon, 27 June 2011 10:18]

Report message to a moderator

Previous Topic:changes in PD3
Next Topic:Looking for download link for PDT SDK package that can be installed through Eclipse, offline.
Goto Forum:
  


Current Time: Fri Jul 25 08:59:44 EDT 2014

Powered by FUDForum. Page generated in 0.02329 seconds