Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Cairo problem in Eclipse 3.6.2 under Linux(An exception occurs while trying to use advanced graphics with Cairo in Eclipse 3.6.2 under Linux)
Cairo problem in Eclipse 3.6.2 under Linux [message #685973] Tue, 21 June 2011 08:16 Go to next message
Armine Maroukhian is currently offline Armine MaroukhianFriend
Messages: 3
Registered: June 2011
Junior Member
Hi, I couldn't find any appropriate topic for the issue being described bellow, so I added a new topic for this.

I was using eclipse 3.2.2 and JDK 1.5 for my SWT project which contained advanced graphics and was working under Linux. Cairo library is responsible for advanced graphics and X Windows under Linux and libcairo-swt.so library is required to have so SWT project could work with advanced graphics. The eclipse 3.2.2 had been extracted from eclipse-SDK-3.2.2-linux-gtk.tar.gz file and my project had been working fine regarding to advanced graphics part and cairo.

Recently, I have updated Eclipse to version 3.6.2 which has been extracted from eclipse-modeling-helios-SR2-incubation-linux-gtk.tar.gz file and updated JDK to 1.6.0_18. After doing so, the project couldn't been loaded and an exception is thrown:

org.eclipse.swt.SWTException: Failed to execute runnable (org.eclipse.swt.SWTException: Unable to load graphics library [Cairo is required] (java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
no swt-cairo-gtk-3659 in java.library.path
no swt-cairo-gtk in java.library.path
/tmp/swtlib-32/libswt-cairo-gtk-3659.so: libcairo.so.2: cannot open shared object file: No such file or directory
Can't load library: /tmp/swtlib-32/libswt-cairo-gtk.so))

at org.eclipse.swt.SWT.error(SWT.java:4083)
at org.eclipse.swt.SWT.error(SWT.java:3998)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:137)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3515)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3164)


The jar version for supporting swt in extracted Eclipse 3.6.2 is org.eclipse.swt_3.6.2.v3659c.jar for Widows and org.eclipse.swt.gtk.linux.x86_3.6.2.v3659b.jar for Linux. libcairo-swt.so library also exists in extracted eclipse v.3.6.2. So it seems that everything should be ok, and the project should be run.

Any help with this is highly appreciated. Maybe some environment variable should be set, or something like that? Or maybe the dependency of libcairo-swt.so should be explicitly set up somewhere?

Thanks a lot,
Armine

Re: Cairo problem in Eclipse 3.6.2 under Linux [message #686016 is a reply to message #685973] Tue, 21 June 2011 11:43 Go to previous messageGo to next message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

You want the SWT forum.

PW


Re: Cairo problem in Eclipse 3.6.2 under Linux [message #686067 is a reply to message #686016] Tue, 21 June 2011 15:05 Go to previous messageGo to next message
Armine Maroukhian is currently offline Armine MaroukhianFriend
Messages: 3
Registered: June 2011
Junior Member
This means that I should place this topic in SWT forum?
Re: Cairo problem in Eclipse 3.6.2 under Linux [message #686094 is a reply to message #686067] Tue, 21 June 2011 17:03 Go to previous message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

yes.
PW


Previous Topic:auto-code completion key-board shortcut
Next Topic:delete perspective
Goto Forum:
  


Current Time: Mon Dec 22 21:21:40 GMT 2014

Powered by FUDForum. Page generated in 0.01685 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software