Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [TEXO] No Texo in Project Properties
[TEXO] No Texo in Project Properties [message #683310] Mon, 13 June 2011 13:44 Go to next message
gdelprete is currently offline gdelprete
Messages: 10
Registered: June 2011
Junior Member
Hello,

i'm trying overriding templates in Texo code generation.

Unfortunately, I cannot find the "Texo" tab in the project's properties dialog which I need to set the templates folder path.

Alternatively, where can I set the templates folder path without using the GUI?

Please note that even if I name the folder "templates" (the default value as per the screenshot on Texo's homepage), may templates are not considered.

Using TEXO stable release (i.e. not nightly releases), under Eclipse Helios SR 2.

Can someone help me?

Regards,
Gabriele

[Updated on: Mon, 13 June 2011 13:45]

Report message to a moderator

Re: [TEXO] [message #683329 is a reply to message #683310] Mon, 13 June 2011 14:09 Go to previous messageGo to next message
Martin Taal is currently offline Martin Taal
Messages: 5339
Registered: July 2009
Senior Member
Hi,
You have to enable the texo nature on the project. Right click on the project and then in the Configure menu choose
add/remove texo nature. Then in the project properties a Texo section appears.

gr. Martin

On 06/13/2011 03:44 PM, forums-noreply@eclipse.org wrote:
> Hello,
>
> i'm trying overriding templates in Texo code generation.
>
> Unfortunately, I cannot find the "Texo" tab in the project's properties dialog which I need to set the templates folder
> path.
>
> Alternatively, where can I set the templates folder path without using the GUI?
>
> Please note that even if I name the folder "templates" (the default value as per the screenshot on Texo's homepage), may
> templates are not considered.
>
> Using TEXO stable release (i.e. not nightly releases), under Eclipse Helios SR 2.
>
> Can someone help me?
>
> Regards,
> Gabriele


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Re: [TEXO] [message #683656 is a reply to message #683329] Tue, 14 June 2011 07:43 Go to previous message
gdelprete is currently offline gdelprete
Messages: 10
Registered: June 2011
Junior Member
Thanks, it did not appear to me as needed as Texo did already generate the model correctly.
Previous Topic:[EEF] EObjectFlatComboViewer and single containment reference
Next Topic:Code genration with EMF
Goto Forum:
  


Current Time: Thu Oct 30 15:27:59 GMT 2014

Powered by FUDForum. Page generated in 0.02694 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software