Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Exported product and new plugin discovey problem
Exported product and new plugin discovey problem [message #68215] Thu, 16 July 2009 16:24 Go to next message
Robert Lewis is currently offline Robert LewisFriend
Messages: 24
Registered: July 2009
Junior Member
I am creating a custom eclipse product for our own language. I have a
product file that depends on two features. One feature includes the set of
internally developed plugins, and the another for required dependencies
for these plugins. When i export the product, i receive an eclipse,
binary, and repository folders. If i place some external plugins into the
eclipse/plugins directory, it will not recognize the new plugins in the
product environment.

After hours of trying to figure out why my development environment could
recognize new plugins, but my product could not, i found a setting in
configuration/config.ini 'org.eclipse.update.reconcile', which i changed
to true and the product continued to find the external plugins.

I have two questions:

1) Why does my development environment have this reconcile option set to
false but still recognize new plugins in if dropped in the plugins folder?
Ideally, i would like to mimic what my development environment is doing
for the product.

2) If i have to set this to true for my product to recognize new plugins,
is there a way to set this option during the export of the product?

Any help is appreciated. Also, please let me know if i'm completely on the
wrong path here. Thanks!

-Rob
Re: Exported product and new plugin discovey problem [message #68254 is a reply to message #68215] Thu, 16 July 2009 19:30 Go to previous message
Robert Lewis is currently offline Robert LewisFriend
Messages: 24
Registered: July 2009
Junior Member
After many more hours of messing around, i think i solved the problem.

Exporting the product creates a
configuration\org.eclipse.equinox.simpleconfigurator\bundles .info entry:
org.eclipse.equinox.p2.reconciler.dropins,1.0.100.v20090520- 1905,plugins/org.eclipse.equinox.p2.reconciler.dropins_1.0.1 00.v20090520-1905.jar,4,false

Changing the autostart parameter before packaging from false to true will
allow discovery of new dropins and plugins without the need for the
config.ini.

-Rob
Re: Exported product and new plugin discovey problem [message #599450 is a reply to message #68215] Thu, 16 July 2009 19:30 Go to previous message
Robert Lewis is currently offline Robert LewisFriend
Messages: 24
Registered: July 2009
Junior Member
After many more hours of messing around, i think i solved the problem.

Exporting the product creates a
configuration\org.eclipse.equinox.simpleconfigurator\bundles .info entry:
org.eclipse.equinox.p2.reconciler.dropins,1.0.100.v20090520- 1905,plugins/org.eclipse.equinox.p2.reconciler.dropins_1.0.1 00.v20090520-1905.jar,4,false

Changing the autostart parameter before packaging from false to true will
allow discovery of new dropins and plugins without the need for the
config.ini.

-Rob
Previous Topic:ctrl+c/v/x in Eclipse 3.5
Next Topic:Semantic highlighting
Goto Forum:
  


Current Time: Fri Nov 28 21:54:43 GMT 2014

Powered by FUDForum. Page generated in 0.02278 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software