Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Error updating product with p2
Error updating product with p2 [message #67980] Fri, 10 July 2009 21:05
Eclipse User
Originally posted by: gaston.tonietti.teracode.com

Hi all,

I post this question here because I got my build with p2 repository generation working following the blog "Building p2 RCP products in Eclipse 3.5M6" which uses PDE Build so let me know if it is not related to
the build but to p2, if so I will ask it in the proper list.

The problem I have is:
I build the product and the repository for version 1.0.0, I launch the application (extracted in a separate folder obviously) then I bump the version to 1.0.1 and run a check for updates in the application.
The needed update is recognized perfectly but when I accept the update operation fails with the following error:

An error occurred while collecting items to be installed
session context was:(profile=profile, phase=org.eclipse.equinox.internal.provisional.p2.engine.pha ses.Collect, operand=[R]com.tc.bom.io 1.0.0 --> [R]com.tc.bom.io 1.0.1, action=).
The required Touchpoint: org.eclipse.equinox.p2.osgi 1.0.0 touchpoint for the collect action is not included in the installation manager configuration.
The required Touchpoint: org.eclipse.equinox.p2.osgi 1.0.0 touchpoint for the collect action is not included in the installation manager configuration.

Could you please point me out how to solve this problem? Is it related to the build or I am doing something wrong?

Tanks a lot.
Gaston.
Previous Topic:Bulding product with one plug-ing having aspects
Next Topic:Error updating product with p2
Goto Forum:
  


Current Time: Fri Oct 31 22:29:47 GMT 2014

Powered by FUDForum. Page generated in 0.14757 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software