Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Objectteams » cannot install OT on Helios
cannot install OT on Helios [message #677394] Wed, 08 June 2011 07:44 Go to next message
Luca Ferrari is currently offline Luca Ferrari
Messages: 159
Registered: November 2009
Senior Member
Hi all,
I'm trying to install the development tools on my Helios, running on java 1.6, but I got an error when computing dependencies:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Object Teams Development Tooling 1.4.0.201003191030 (org.objectteams.otdt.feature.group 1.4.0.201003191030)
  Missing requirement: OTDT Core Patch Feature 1.4.0.201003191030 (org.objectteams.otdt.core.patch.feature.group 1.4.0.201003191030) requires 'org.eclipse.jdt.feature.group [3.6.0.v20100308-1800-7z8XFRBFMTdeDrqFpIInkeg45027]' but it could not be found
  Cannot satisfy dependency:
    From: Object Teams Development Tooling 1.4.0.201003191030 (org.objectteams.otdt.feature.group 1.4.0.201003191030)
    To: org.objectteams.otdt.core.patch.feature.group [1.4.0.201003191030]


The fact is that I'm running eclipse 3.6.2, so I don't get wy it is asking me a feature 3.6.0, maybe I'm getting wrong these version numbers.

However I tried to install the 1.3 version and got the following error:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Object Teams Development Tooling 1.3.3.201002242017 (org.objectteams.otdt.feature.group 1.3.3.201002242017)
  Software currently installed: Eclipse Platform SDK 3.6.2.M20110210-1200 (org.eclipse.platform.sdk 3.6.2.M20110210-1200)
  Only one of the following can be installed at once: 
    OSGi System Bundle 3.6.2.R36x_v20110210 (org.eclipse.osgi 3.6.2.R36x_v20110210)
    OSGi System Bundle 3.6.1.R36x_v20100806 (org.eclipse.osgi 3.6.1.R36x_v20100806)
    OSGi System Bundle 3.5.2.R35x_v20100126 (org.eclipse.osgi 3.5.2.R35x_v20100126)
    OSGi System Bundle 3.6.0.v20100517 (org.eclipse.osgi 3.6.0.v20100517)
    OSGi System Bundle 3.5.1.R35x_v20090827 (org.eclipse.osgi 3.5.1.R35x_v20090827)
    OSGi System Bundle 3.5.0.v20090520 (org.eclipse.osgi 3.5.0.v20090520)
    OSGi System Bundle 3.5.1.R35x_v20090806 (org.eclipse.osgi 3.5.1.R35x_v20090806)
    OSGi System Bundle 3.5.2.R35x_v20100105 (org.eclipse.osgi 3.5.2.R35x_v20100105)
  Cannot satisfy dependency:
    From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)
    To: org.eclipse.rcp.feature.group [3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY]
  Cannot satisfy dependency:
    From: Eclipse Platform SDK 3.6.2.M20110210-1200 (org.eclipse.platform.sdk 3.6.2.M20110210-1200)
    To: org.eclipse.platform.feature.group [3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY (org.eclipse.rcp.feature.group 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY)
    To: org.eclipse.osgi [3.6.2.R36x_v20110210]
  Cannot satisfy dependency:
    From: Adaptor for the JDT/APT 1.3.2.200909280002 (org.objectteams.otdt.apt.adaptor 1.3.2.200909280002)
    To: bundle org.objectteams.otequinox [1.2.6,2.0.0)
  Cannot satisfy dependency:
    From: Object Teams Development Tooling 1.3.3.201002242017 (org.objectteams.otdt.feature.group 1.3.3.201002242017)
    To: org.objectteams.otdt.apt.adaptor [1.3.2.200909280002]
  Cannot satisfy dependency:
    From: ObjectTeams/Equinox Integration 1.3.0.200905130029 (org.objectteams.otequinox 1.3.0.200905130029)
    To: bundle org.eclipse.osgi [3.5.0.v20090413,3.6.0]
  Cannot satisfy dependency:
    From: ObjectTeams/Equinox Integration 1.3.0.200905161144 (org.objectteams.otequinox 1.3.0.200905161144)
    To: bundle org.eclipse.osgi [3.5.0.v20090413,3.6.0]
  Cannot satisfy dependency:
    From: ObjectTeams/Equinox Integration 1.3.0.200905201705 (org.objectteams.otequinox 1.3.0.200905201705)
    To: bundle org.eclipse.osgi [3.5.0.v20090413,3.6.0]
  Cannot satisfy dependency:
    From: ObjectTeams/Equinox Integration 1.3.0.200905250227 (org.objectteams.otequinox 1.3.0.200905250227)
    To: bundle org.eclipse.osgi [3.5.0.v20090413,3.6.0)
  Cannot satisfy dependency:
    From: ObjectTeams/Equinox Integration 1.3.0.200906020253 (org.objectteams.otequinox 1.3.0.200906020253)
    To: bundle org.eclipse.osgi [3.5.0.v20090413,3.6.0)
  Cannot satisfy dependency:
    From: ObjectTeams/Equinox Integration 1.3.0.200906230207 (org.objectteams.otequinox 1.3.0.200906230207)
    To: bundle org.eclipse.osgi [3.5.0.v20090413,3.6.0)
  Cannot satisfy dependency:
    From: ObjectTeams/Equinox Integration 1.3.1.200908121010 (org.objectteams.otequinox 1.3.1.200908121010)
    To: bundle org.eclipse.osgi [3.5.0.v20090413,3.6.0)
  Cannot satisfy dependency:
    From: ObjectTeams/Equinox Integration 1.3.2.200909280002 (org.objectteams.otequinox 1.3.2.200909280002)
    To: bundle org.eclipse.osgi [3.5.0.v20090413,3.6.0)
  Cannot satisfy dependency:
    From: ObjectTeams/Equinox Integration 1.3.3.201002242017 (org.objectteams.otequinox 1.3.3.201002242017)
    To: bundle org.eclipse.osgi [3.5.0.v20090413,3.6.0)


and this time the error seems also worst! Any suggestion?

Thanks
Re: cannot install OT on Helios [message #677409 is a reply to message #677394] Wed, 08 June 2011 08:42 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan Herrmann
Messages: 999
Registered: July 2009
Senior Member
Hi Luca,

The error you are seeing is probably caused by the fact
that the OTDT 1.4.0 was build for Eclipse 3.6 Milestone 6
and will not work for 3.6.2.

When installing into Eclipse Helios please use version 0.7.x from
http://download.eclipse.org/objectteams/updates/0.7

Yes, 0.7.x is newer than 1.4.0. This page has some more info:
http://www.eclipse.org/objectteams/download.php

Please report back here, if you are still having problems,

thanks,
Stephan
Re: cannot install OT on Helios [message #682022 is a reply to message #677409] Fri, 10 June 2011 04:54 Go to previous messageGo to next message
Luca Ferrari is currently offline Luca Ferrari
Messages: 159
Registered: November 2009
Senior Member
Uhm...I tried the update link but eclipse says there are no updates available at such url, and in fact:

$ wget http://download.eclipse.org/objectteams/update/0.7/
--2011-06-10 10:50:25--  http://download.eclipse.org/objectteams/update/0.7/
Connecting to 10.8.1.236:8080... connected.
Proxy request sent, awaiting response... 404 Not Found
2011-06-10 10:50:26 ERROR 404: Not Found.


Maybe there is a problem with an update site? Or it could be a problem of my computer, but other updates are working.
Re: cannot install OT on Helios [message #682193 is a reply to message #682022] Fri, 10 June 2011 11:27 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan Herrmann
Messages: 999
Registered: July 2009
Senior Member
Luca Ferrari wrote on Fri, 10 June 2011 10:54
Uhm...I tried the update link but eclipse says there are no updates available at such url, and in fact:

$ wget http://download.eclipse.org/objectteams/update/0.7/
--2011-06-10 10:50:25--  http://download.eclipse.org/objectteams/update/0.7/
Connecting to 10.8.1.236:8080... connected.
Proxy request sent, awaiting response... 404 Not Found
2011-06-10 10:50:26 ERROR 404: Not Found.


Maybe there is a problem with an update site? Or it could be a problem of my computer, but other updates are working.


darn it, in preparation for the 2.0.0 release I recently moved that update site from download.eclipse.org to archive.eclipse.org, which should be transparently redirected. But as I can see now, too, this (currently) doesn't work.

For the moment, could you please directly try
http://archive.eclipse.org/objectteams/updates/0.7/
instead? This seems to be working.

sorry for the inconvenience!
Stephan
Re: cannot install OT on Helios [message #685320 is a reply to message #682193] Fri, 17 June 2011 05:18 Go to previous messageGo to next message
Luca Ferrari is currently offline Luca Ferrari
Messages: 159
Registered: November 2009
Senior Member
Thanks, it worked.
Re: cannot install OT on Helios [message #1064183 is a reply to message #682193] Tue, 18 June 2013 02:58 Go to previous messageGo to next message
VR Babu is currently offline VR Babu
Messages: 2
Registered: June 2013
Junior Member
Hi,

I am having same issue while installing a plug in. Please suggest.

Cannot complete the install because of a conflicting dependency.
Software being installed: JSDT jQuery Integration 1.6.0 (org.eclipselabs.jsdt.jquery_feature.feature.group 1.6.0)
Software currently installed: Eclipse Platform 3.6.2.M20110210-1200 (org.eclipse.platform.ide 3.6.2.M20110210-1200)
Only one of the following can be installed at once:
Eclipse Preferences Mechanism 3.3.0.v20100503 (org.eclipse.equinox.preferences 3.3.0.v20100503)
Eclipse Preferences Mechanism 3.5.0.v20120522-1841 (org.eclipse.equinox.preferences 3.5.0.v20120522-1841)
Eclipse Preferences Mechanism 3.5.1.v20121031-182809 (org.eclipse.equinox.preferences 3.5.1.v20121031-182809)
Cannot satisfy dependency:
From: Core Runtime 3.8.0.v20120521-2346 (org.eclipse.core.runtime 3.8.0.v20120521-2346)
To: bundle org.eclipse.equinox.preferences [3.4.0,4.0.0)
Re: cannot install OT on Helios [message #1064258 is a reply to message #1064183] Tue, 18 June 2013 09:07 Go to previous message
Stephan Herrmann is currently offline Stephan Herrmann
Messages: 999
Registered: July 2009
Senior Member
sorry, but that's *not* the *same* problem Smile

I know in Helios the reporting of install incompatibilities wasn't very user friendly, but nowhere in your error message can I see Object Teams having a finger in the pie.

You may want to consult with the developers of JSDT jQuery Integration on what their plug-ins requirements are.

Be prepared to provide to them more information on what exactly you have installed, and what you are trying to install / update.
Previous Topic:"Object Teams Patch for JDT/Core" issue on update
Next Topic:Cannot complete the install because of a conflicting dependency
Goto Forum:
  


Current Time: Sat Aug 30 10:38:40 EDT 2014

Powered by FUDForum. Page generated in 0.01733 seconds