Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » ** Indigo java.binaries / dependency issue
** Indigo java.binaries / dependency issue [message #676925] Tue, 07 June 2011 01:32
Miles Parker is currently offline Miles Parker
Messages: 1339
Registered: July 2009
Senior Member
Hi guys,

I'm almost tempted to put "HELP!!" " in the subject line, ala those "this is really important because my homework is due tomorrow" messages, but this is really important because my release is due tomorrow and naturally something new just broke. I've started getting:

INFO: perform '--properties' '/opt/users/hudsonbuild/workspace/amp-nightly/buildroot/build.properties' '-Dbuckminster.reference.repository=https://hudson.eclipse.org/hudson/job/amp-nightly/lastSuccessfulBuild/artifact/amp.p2.repository/' 'org.eclipse.amp.build#build'
CSpec org.apache.lucene:osgi.bundle$2.9.1.v201101211721 has no action, group, or local artifact named java.binaries

From earlier traffic on cross-projects list, I understand that this can be a signal that there is a dependency issue somewhere? I found such an issue -- I'm depending on birt datatools which has a dependency on org.apache.lucene 1.9.1, while everyone else in the Eclipse universe is using 2.9.1. I've got an email to them asking them to update to 2.9 if at all possible but can you confirm that this kind of whole number difference could be the cause of the issue? If so is there any other recourse if I can't get BIRT to change dependency versioining?

thanks!

Miles

[Updated on: Tue, 07 June 2011 01:33]

Report message to a moderator

Previous Topic:Product IU with buckminster
Next Topic:My RMAP is not working anymore
Goto Forum:
  


Current Time: Wed Sep 03 02:27:55 GMT 2014

Powered by FUDForum. Page generated in 0.01613 seconds