Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Installation problem
Installation problem [message #676385] Sat, 04 June 2011 04:09 Go to next message
Tomas Balderas is currently offline Tomas Balderas
Messages: 46
Registered: July 2010
Member
Hello. I hope any of you be so kind to help me with my problem. I had to install Eclipse and all of the plugins I used (ATL, UML2 Tools and Papyrus). The installation of Papyrus failed. I tride two methods:

1. Using Help->Install Modeling Component
2. Using Help->Install New Software...

When using the second option I got the messages below. I tried to install the package EPF but cannot find it. Does any of you know the solution to my problem? I really appreciate your help, since I am novice in Eclipse.


Cannot complete the install because one or more required items could not be found.
Software being installed: MDT Papyrus - SDK: Runtime, Tools, Documentation and sources (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.sdk.feature.group 0.7.3.v201104270854)
Missing requirement for filter properties ~= $0: EPF Richtext 1.6.0.201101131810 (org.eclipse.epf.richtext.feature.group 1.6.0.201101131810) requires 'org.eclipse.epf.common.win32.win32.x86 [1.5.0.201101131810]' but it could not be found
Cannot satisfy dependency:
From: MDT Papyrus - Backbone (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.backbone.feature.group 0.7.3.v201104270854)
To: org.eclipse.epf.richtext.feature.group [1.6.0.201101131810]
Cannot satisfy dependency:
From: MDT Papyrus - Runtime and Tools (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.feature.group 0.7.3.v201104270854)
To: org.eclipse.papyrus.backbone.feature.group [0.7.3.v201104270854]
Cannot satisfy dependency:
From: MDT Papyrus - SDK: Runtime, Tools, Documentation and sources (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.sdk.feature.group 0.7.3.v201104270854)
To: org.eclipse.papyrus.feature.group [0.7.3.v201104270854]


/TB
Re: Installation problem [message #677330 is a reply to message #676385] Wed, 08 June 2011 08:03 Go to previous messageGo to next message
Sebastien Gerard is currently offline Sebastien Gerard
Messages: 115
Registered: July 2009
Senior Member
Hi,

sorry for the late response. Do you still have a problem?

Best... S├ębastien.
Re: Installation problem [message #677561 is a reply to message #676385] Wed, 08 June 2011 20:22 Go to previous messageGo to next message
Yann Tanguy is currently offline Yann Tanguy
Messages: 80
Registered: July 2009
Member
I just tried the following install procedure without trouble (on win7):

1. Using Help->Install Modeling Component

- Download Eclipse Modeling Helios SR2 (32 Bit version)
- Help / Install Modeling Components
- Just select Papyrus (its 0.7.3.v201104270854),
- Validate everything, and reboot

2. Using Help->Install New Software...

- Download Eclipse Modeling Helios SR2 (32 Bit version)
- Help / Install New Software
- Add update site : "http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/helios"
- Only select "MDT Papyrus - SDK: Runtime..."
- Validate everything and reboot

---------------

Maybe I'm wrong but the EPF plug-in required by Papyrus might be platform dependent and causing issues with install on Windows 64 Bit version of eclipse, Linux or MacOS.

---------------

[Updated on: Wed, 08 June 2011 20:26]

Report message to a moderator

Re: Installation problem [message #677587 is a reply to message #677330] Wed, 08 June 2011 21:40 Go to previous messageGo to next message
Tomas Balderas is currently offline Tomas Balderas
Messages: 46
Registered: July 2010
Member
Hello Sebastien

Unfortunately I still have problems. I installed Helios Service Release 2 Build id: 20110218-0911 (the x86-64 version of Eclipse Helios) and still getting the same error messages:

1. When I select Help->Install Modeling Components I get
Problems occurred while performing installation: Operation details

2. When I select Help->Install New Software... I get the messages below when trying to install Papyrus All (0.7.3.v201104270854).

I found a thread in this forum where the same issue is addressed, but no solution was reported other than switching to the 32-bit version of Eclipse Helios.

Thank you. Kindest regards.

----------------------------------------------------------------------------------
Cannot complete the install because one or more required items could not be found.
Software being installed: MDT Papyrus - SDK: Runtime, Tools, Documentation and sources (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.sdk.feature.group 0.7.3.v201104270854)
Missing requirement for filter properties ~= $0: EPF Richtext 1.6.0.201101131810 (org.eclipse.epf.richtext.feature.group 1.6.0.201101131810) requires 'org.eclipse.epf.common.win32.win32.x86 [1.5.0.201101131810]' but it could not be found
Cannot satisfy dependency:
From: MDT Papyrus - Backbone (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.backbone.feature.group 0.7.3.v201104270854)
To: org.eclipse.epf.richtext.feature.group [1.6.0.201101131810]
Cannot satisfy dependency:
From: MDT Papyrus - Runtime and Tools (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.feature.group 0.7.3.v201104270854)
To: org.eclipse.papyrus.backbone.feature.group [0.7.3.v201104270854]
Cannot satisfy dependency:
From: MDT Papyrus - SDK: Runtime, Tools, Documentation and sources (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.sdk.feature.group 0.7.3.v201104270854)
To: org.eclipse.papyrus.feature.group [0.7.3.v201104270854]


/TB
Re: Installation problem [message #684240 is a reply to message #677587] Wed, 15 June 2011 09:26 Go to previous messageGo to next message
LordMax is currently offline LordMax
Messages: 3
Registered: June 2011
Location: Turin (IT)
Junior Member

HI

I'm on Galileo on a LInux Mint 32 bit OS and I can't install papyrus.
CAn you confirm me that's a Galileo problem?
Re: Installation problem [message #684265 is a reply to message #684240] Wed, 15 June 2011 10:03 Go to previous messageGo to next message
Yann Tanguy is currently offline Yann Tanguy
Messages: 80
Registered: July 2009
Member
AFAIK there is no Galileo version of Papyrus.

Moreover, the error details you gave in your other post shows that you try to install Papyrus V0.8, which requires Indigo.

[Updated on: Wed, 15 June 2011 10:04]

Report message to a moderator

Re: Installation problem [message #690013 is a reply to message #677330] Tue, 28 June 2011 19:05 Go to previous messageGo to next message
Tomas Balderas is currently offline Tomas Balderas
Messages: 46
Registered: July 2010
Member
I have this installation problem when trying to install the release 0.7.3.v201104270854. I have just realized that there are a number of builds corresponding to the release 0.8.0. Does this release 0.8.0 fix any of the installation issues? If so I will download it and install it.

/TB
Re: Installation problem [message #690201 is a reply to message #690013] Wed, 29 June 2011 07:08 Go to previous messageGo to next message
Yann Tanguy is currently offline Yann Tanguy
Messages: 80
Registered: July 2009
Member
No install problem with 0.7 (Helios) or 0.8 (Indigo) with the Eclipse Win32 version, for other bundles I can't say.
Re: Installation problem [message #690330 is a reply to message #690201] Wed, 29 June 2011 11:46 Go to previous messageGo to next message
Tomas Balderas is currently offline Tomas Balderas
Messages: 46
Registered: July 2010
Member
I've tried to install Papyrus 0.8.0 on Eclipse Helios for x86-64 and failed. It's such a shame Sad

/TB
Re: Installation problem [message #690431 is a reply to message #690330] Wed, 29 June 2011 14:13 Go to previous messageGo to next message
Yann Tanguy is currently offline Yann Tanguy
Messages: 80
Registered: July 2009
Member
Papyrus 0.8 requires Indigo, not Helios.
It would probably fail as well as far as you try to use Eclipse 64 bit version anyway.

Don't know if a bug entry has already been entered for this, if not feel free to add one.
Re: Installation problem [message #693202 is a reply to message #690431] Wed, 06 July 2011 02:12 Go to previous message
Tomas Balderas is currently offline Tomas Balderas
Messages: 46
Registered: July 2010
Member
I have moved to Eclipse Indigo and installed Papyrus 0.8.0 successfully. I hope not to have installation problems anymore. So, case closed.

Thanks. Kindest regards.


/TB
Previous Topic:Operation parameters
Next Topic:Adding a return type
Goto Forum:
  


Current Time: Fri Sep 19 01:47:51 GMT 2014

Powered by FUDForum. Page generated in 0.02375 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software