Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Hyperlinks do not work in PDF format(Hyperlinks containing simplified Chinese characters do not work in PDF)
Hyperlinks do not work in PDF format [message #674447] Thu, 26 May 2011 19:34 Go to next message
Joseph Yeh is currently offline Joseph Yeh
Messages: 12
Registered: July 2009
Junior Member
I need help on the hyperlink issue I am encountering. Here is a description of the issue.

In my report design, I have created a bookmark on a table group header. The bookmark is constructed using a data such as row["ID"]. The hyperlink is defined on a cell of another table with Internal Bookmark as the type and the same expression as the bookmark.

The hyperlinks work fine with the PDF format if the data contains English characters. However, if the data contains a Simplified Chinese character, the link will not work when the report is generated in PDF format. I have not tried Traditional Chinese characters. If I generate the report in HTML format, the links work fine.

My design was created using Eclipse BIRT Designer Version 2.3.2.r232_20090202.

I am fairly new to BIRT, so I wonder if I have missed anything in the design. I will appreciate any help and guide you can provide.

Regards,
Joseph
Re: Hyperlinks do not work in PDF format [message #675468 is a reply to message #674447] Tue, 31 May 2011 11:48 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Joseph,

Can you try this with the latest BIRT (2.6.2)?

Jason

On 5/26/2011 7:34 PM, Joseph Yeh wrote:
> I need help on the hyperlink issue I am encountering. Here is a
> description of the issue.
>
> In my report design, I have created a bookmark on a table group header.
> The bookmark is constructed using a data such as row["ID"]. The
> hyperlink is defined on a cell of another table with Internal Bookmark
> as the type and the same expression as the bookmark.
>
> The hyperlinks work fine with the PDF format if the data contains
> English characters. However, if the data contains a Simplified Chinese
> character, the link will not work when the report is generated in PDF
> format. I have not tried Traditional Chinese characters. If I generate
> the report in HTML format, the links work fine.
>
> My design was created using Eclipse BIRT Designer Version
> 2.3.2.r232_20090202.
>
> I am fairly new to BIRT, so I wonder if I have missed anything in the
> design. I will appreciate any help and guide you can provide.
>
> Regards,
> Joseph
Re: Hyperlinks do not work in PDF format [message #675522 is a reply to message #675468] Tue, 31 May 2011 14:16 Go to previous messageGo to next message
Joseph Yeh is currently offline Joseph Yeh
Messages: 12
Registered: July 2009
Junior Member
Hi Jason,

This works in BIRT 2.6.2. The design will be rendered using BIRT API in an environment which is based on Eclipse 3.4.2 integrated with BIRT 2.3.2. The environment will not change for quite a while. Is this a bug that has been fixed after the 2.3.2 release?

Regards,
Joseph
Re: Hyperlinks do not work in PDF format [message #675561 is a reply to message #675522] Tue, 31 May 2011 15:48 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Joseph,

I could not find a bug number on this but I assume it was fixed post 2.3.2.

Jason

On 5/31/2011 2:16 PM, Joseph Yeh wrote:
> Hi Jason,
>
> This works in BIRT 2.6.2. The design will be rendered using BIRT API in
> an environment which is based on Eclipse 3.4.2 integrated with BIRT
> 2.3.2. The environment will not change for quite a while. Is this a bug
> that has been fixed after the 2.3.2 release?
>
> Regards,
> Joseph
Previous Topic:Passing Dynamic values to OrderBy Clause
Next Topic:Counting on a xml data sources
Goto Forum:
  


Current Time: Wed Aug 20 20:36:38 EDT 2014

Powered by FUDForum. Page generated in 0.01629 seconds