Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » Help with WindowBuilder Pro XWT Application Wizard
Help with WindowBuilder Pro XWT Application Wizard [message #673839] Tue, 24 May 2011 22:50 Go to next message
Eric  is currently offline Eric Friend
Messages: 5
Registered: May 2011
Junior Member
Hi guys,

I am trying to use the WindoBuilder Pro XWT Application Wizard but I
keep seeing an error, and I don't know how to fix it. If anyone could
help me I would greatly appreciate it.

Here is what I did:
1) Install Java
2) Install Eclipse
3) Install WindowBuilder Pro Eclipse plugin (checked all boxes)
4) File->New->Project->WindowBuilder\SWT Designer\SWT/JFace Java Project
5) Ctrl-N->WindowBuilder\SWT Designer\XWT\XWT Application

At this point I am able to see my window in the editor, add controls,
modify it, edit the code, etc.

But when I right click the application -> run as -> Java Application
then I get this error message:

Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/
core/databinding/conversion/IConverter
at org.eclipse.e4.xwt.XWTLoaderManager.<clinit>(XWTLoaderManager.java:19)
at org.eclipse.e4.xwt.XWT.load(XWT.java:379)
at com.Eric.SomeXwtApplication.main(SomeXwtApplication.java:16)
Caused by: java.lang.ClassNotFoundException:
org.eclipse.core.databinding.conversion.IConverter
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 3 more

I don't know how to troubleshoot this, am I missing a reference? Why
is the WindowBuilder Pro XWT application wizard not giving me the
reference?

Thanks,
Eric
Re: Help with WindowBuilder Pro XWT Application Wizard [message #673871 is a reply to message #673839] Wed, 25 May 2011 02:32 Go to previous messageGo to next message
Eric  is currently offline Eric Friend
Messages: 5
Registered: May 2011
Junior Member
I figured it out myself,

I needed to add three .jar's to my project's references,
org.eclipse.core.databinding
org.eclipse.core.databinding.observable
org.eclipse.jface.databinding

I did that by clicking Project -> Properties -> Java Build Path ->
Libraries, Add External Jar's, and then I browsed to c:\eclipse
\plugins and found the .jars there and added them.

But, doesn't it seem like those jar's should have been added by the XWT Application Wizard? Is this a bug? Should users have to manually add those .jar's every time they create an XWT Application?
Re: Help with WindowBuilder Pro XWT Application Wizard [message #674075 is a reply to message #673871] Wed, 25 May 2011 18:11 Go to previous messageGo to next message
Konstantin Scheglov is currently offline Konstantin ScheglovFriend
Messages: 555
Registered: July 2009
Senior Member
https://bugs.eclipse.org/bugs/show_bug.cgi?id=347202

Konstantin Scheglov,
Google, Inc.
Re: Help with WindowBuilder Pro XWT Application Wizard [message #674105 is a reply to message #674075] Wed, 25 May 2011 20:40 Go to previous message
Eric  is currently offline Eric Friend
Messages: 5
Registered: May 2011
Junior Member
Outstanding, thank you!
Previous Topic:Custom Method
Next Topic:Property editor instanceObject
Goto Forum:
  


Current Time: Sat Nov 29 05:24:00 GMT 2014

Powered by FUDForum. Page generated in 0.06586 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software