Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Update problems(Papyrus update failed)
Update problems [message #673680] Tue, 24 May 2011 13:10 Go to next message
Steve Blackwell is currently offline Steve BlackwellFriend
Messages: 30
Registered: May 2011
Member
Yesterday I tried to run an update in Eclipse by switching to the Java perspective and selecting Help->Check for Updates. The update failed with the messages below. What I can understand from this (and I think it is not very clear) is that some software that was not updated (not sure which) requires EPF Common v1.2.0 and the version of Papyrus (v0.8.0.v201105241213) that would have been installed by the update requires EPF Common v1.5.0 and both EPF Common versions cannot be installes at the same time.

2 questions:
Have I interpreted these messages correctly?
How do I go about correcting the problem?

Thanks,
Steve

Cannot complete the install because of a conflicting dependency.
Software being installed: MDT Papyrus - SDK: Runtime, Tools, Documentation and sources (Incubation) 0.8.0.v201105241213 (org.eclipse.papyrus.sdk.feature.group 0.8.0.v201105241213)
Software currently installed: Extended Editing Framework - SDK (Incubation) 0.9.0.v20110314-1429 (org.eclipse.emf.eef.sdk.feature.group 0.9.0.v20110314-1429)
Only one of the following can be installed at once:
EPF Common 1.2.0.v20110314-1429 (org.eclipse.epf.common 1.2.0.v20110314-1429)
EPF Common 1.5.0.201105160919 (org.eclipse.epf.common 1.5.0.201105160919)
Cannot satisfy dependency:
From: Extended Editing Framework - Extension (Incubation) 0.9.0.v20110314-1429 (org.eclipse.emf.eef.extended.feature.group 0.9.0.v20110314-1429)
To: org.eclipse.epf.common [1.2.0.v20110314-1429]
Cannot satisfy dependency:
From: Extended Editing Framework - SDK (Incubation) 0.9.0.v20110314-1429 (org.eclipse.emf.eef.sdk.feature.group 0.9.0.v20110314-1429)
To: org.eclipse.emf.eef.extended.feature.group [0.9.0.v20110314-1429]
Cannot satisfy dependency:
From: EPF Richtext 1.6.0.201105160919 (org.eclipse.epf.richtext.feature.group 1.6.0.201105160919)
To: org.eclipse.epf.common [1.5.0.201105160919]
Cannot satisfy dependency:
From: MDT Papyrus - Backbone (Incubation) 0.8.0.v201105241213 (org.eclipse.papyrus.backbone.feature.group 0.8.0.v201105241213)
To: org.eclipse.epf.richtext.feature.group [1.6.0.201105160919]
Cannot satisfy dependency:
From: MDT Papyrus - Runtime and Tools (Incubation) 0.8.0.v201105241213 (org.eclipse.papyrus.feature.group 0.8.0.v201105241213)
To: org.eclipse.papyrus.backbone.feature.group [0.8.0.v201105241213]
Cannot satisfy dependency:
From: MDT Papyrus - SDK: Runtime, Tools, Documentation and sources (Incubation) 0.8.0.v201105241213 (org.eclipse.papyrus.sdk.feature.group 0.8.0.v201105241213)
To: org.eclipse.papyrus.feature.group [0.8.0.v201105241213]
Re: Update problems [SOLVED] [message #674060 is a reply to message #673680] Wed, 25 May 2011 17:11 Go to previous messageGo to next message
Steve Blackwell is currently offline Steve BlackwellFriend
Messages: 30
Registered: May 2011
Member
I uninstalled the
Extended Editing Framework - SDK (Incubation) 0.9.0.v20110314-1429
and then I was able to update Papyrus to v0.8.0.v201105250947.

After that I installed:
Extended Editing Framework - EMF Edit generation using Acceleo 1.0.0.v20110506-1424
Extended Editing Framework - SDK for Indigo 1.0.0.v20110506-1424

A packaging bug?
Re: Update problems [SOLVED] [message #675073 is a reply to message #674060] Mon, 30 May 2011 08:38 Go to previous message
Patrick Tessier is currently offline Patrick TessierFriend
Messages: 142
Registered: July 2009
Senior Member
It is strange that EEF do not use the last version of epf or set a minimum version
Previous Topic:Noob questions
Next Topic:Class diagram observations
Goto Forum:
  


Current Time: Thu Nov 27 16:23:09 GMT 2014

Powered by FUDForum. Page generated in 0.12868 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software