Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Failed to Load JavaHL Library
Failed to Load JavaHL Library [message #672497] Sat, 21 May 2011 10:12 Go to next message
thoufiq  is currently offline thoufiq Friend
Messages: 16
Registered: May 2011
Junior Member
Hello All,
I had installed eclipse-IDE in my ubuntu server, it is working fine but while giving the SVN repository location it shows error like this..

Failed to load JavaHL Library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path = /usr/lib/jvm/java-6-sun-1.6.0.24/jre/lib/i386/client:/usr/lib/jvm/java-6-sun-1.6.0.24/jre/lib/i386:/usr/lib/xulrunner-1.9.2.17:/usr/lib/xulrunner-1.9.2.17:/usr/lib/xulrunner-1.9.2.17:/usr/lib/xulrunner-1.9.2.17:/usr/lib/xulrunner-1.9.2.17:/usr/lib/xulrunner-1.9.2.17:/usr/lib/xulrunner-1.9.2.17:/usr/lib/xulrunner-1.9.2.17:/usr/lib/xulrunner-1.9.2.17:/usr/lib/xulrunner-1.9.2.17:/usr/java/packages/lib/i386:/lib:/usr/lib


Anyone Suggest me to fix this issue...

Thanks
Re: Failed to Load JavaHL Library [message #673247 is a reply to message #672497] Mon, 23 May 2011 02:01 Go to previous messageGo to next message
thoufiq  is currently offline thoufiq Friend
Messages: 16
Registered: May 2011
Junior Member
Any one help me guys.......



Thanks
Re: Failed to Load JavaHL Library [message #673257 is a reply to message #672497] Mon, 23 May 2011 03:34 Go to previous messageGo to next message
nicole_coocox  is currently offline nicole_coocox Friend
Messages: 13
Registered: April 2011
Junior Member
First you need to install libsvn-java .

Then alter the eclipse system configuration utility,adding such parameter:
VMARGS="-Djava.library.path=/usr/lib/jni"

That will be useful.You can try it.



Free and Open embedded development tools --- CooCox.
Re: Failed to Load JavaHL Library [message #673279 is a reply to message #673257] Mon, 23 May 2011 05:30 Go to previous messageGo to next message
thoufiq  is currently offline thoufiq Friend
Messages: 16
Registered: May 2011
Junior Member
Hi Nicole,
I had re-installed eclipse in my ubuntu server 10.10 and it is working fine but while trying to install eclipse subversion, i got a error that can't complete the install.
I clicked the menu HELP > Install new software and added the link Subclipse_1.6.x - http://subclipse.tigris.org/update_1.6.x then i got core SVNkit library, Optional JNA library and subclipse to install, then i marked all the three items and proceed to NEXT, after that it shows error like this.....


Quote:
Cannot complete the install because one or more required items could not be found.
Software being installed: Subclipse Integration for Mylyn 3.x (Optional) 3.0.0 (org.tigris.subversion.subclipse.mylyn.feature.gro up 3.0.0)
Missing requirement: Subclipse Integration for Mylyn 3.x (Optional) 3.0.0 (org.tigris.subversion.subclipse.mylyn.feature.gro up 3.0.0) requires 'org.eclipse.mylyn.tasks.core [3.0.0,4.0.0)' but it could not be found



Help me to fix this issue


Thanks

[Updated on: Mon, 23 May 2011 05:34]

Report message to a moderator

Re: Failed to Load JavaHL Library [message #673460 is a reply to message #673279] Mon, 23 May 2011 17:43 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2406
Registered: July 2009
Senior Member
On 5/23/11 1:30 AM, thoufiq wrote:
> I had re-installed eclipse in my ubuntu server 10.10 and it is working
> fine but while trying to install eclipse subversion, i got a error that
> can't complete the install.
> I clicked the menu HELP > Install new software and added the link
> Subclipse_1.6.x - http://subclipse.tigris.org/update_1.6.x then i got
> core SVNkit library, Optional JNA library and subclipse to install, then
> i marked all the three items and proceed to NEXT, after that it shows
> error like this.....
>
>
> Quote:
>> Cannot complete the install because one or more required
>> items could not be found.
>> Software being installed: Subclipse Integration for Mylyn 3.x
>> (Optional) 3.0.0 (org.tigris.subversion.subclipse.mylyn.feature.gro up
>> 3.0.0)
>> Missing requirement: Subclipse Integration for Mylyn 3.x (Optional)
>> 3.0.0 (org.tigris.subversion.subclipse.mylyn.feature.gro up 3.0.0)
>> requires 'org.eclipse.mylyn.tasks.core [3.0.0,4.0.0)' but it could not
>> be found
>> Anyone help me to fix this issue..
>>

>
>
>
> Help me to fix this issue

If you're not using Mylyn, then just un-select the "Subclipse
Integration for Mylyn" component when choosing what to install.

Eric
Re: Failed to Load JavaHL Library [message #673544 is a reply to message #673460] Tue, 24 May 2011 04:39 Go to previous messageGo to next message
thoufiq  is currently offline thoufiq Friend
Messages: 16
Registered: May 2011
Junior Member
Hello Eric,
I un-marked the Mylyn and installed other components but after installing subversion, svn perspective is not present in the WINDOW > Show view > other and also in WINDOW > Open perspective > other. I think plugins are not installed but i dont know the actual cause for this issue.


Can you suggest me to fix this issue.




Thanks

[Updated on: Tue, 24 May 2011 08:49]

Report message to a moderator

Re: Failed to Load JavaHL Library [message #673888 is a reply to message #673544] Wed, 25 May 2011 04:46 Go to previous messageGo to next message
thoufiq  is currently offline thoufiq Friend
Messages: 16
Registered: May 2011
Junior Member
Anyone help me guys...........



Thanks
Re: Failed to Load JavaHL Library [message #675026 is a reply to message #673888] Mon, 30 May 2011 05:11 Go to previous messageGo to next message
thoufiq  is currently offline thoufiq Friend
Messages: 16
Registered: May 2011
Junior Member
Hello all,
I am waiting for the reply for my post named FAILED TO LOAD JAVAHL from 25th may 2011 but no one is replied to me. I don't know why the peoples are not responding to my post.
Pls pls pls...any one help me to overcome this issue.
Re: Failed to Load JavaHL Library [message #675207 is a reply to message #675026] Mon, 30 May 2011 15:05 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3265
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2011.05.29 23:11, thoufiq wrote:
> Hello all,
> I am waiting for the reply for my post named FAILED TO LOAD JAVAHL from
> 25th may 2011 but no one is replied to me. I don't know why the peoples
> are not responding to my post.
> Pls pls pls...any one help me to overcome this issue.

Thoufiq,

Think about how this forum works: unpaid folk answering questions when
a) they happen to know and b) they happen to get to the forum. I get to
this forum a couple of times per day. I just don't happen to know the
answer to your specific question.

Bumping the forum will never produce an answer faster, but, get this: it
may result in someone ignoring you who otherwise may have been happy to
answer.

Nevertheless, ...

I have written up my own experiences installing and using Subversion
with Eclipse. You're welcome to peruse my page, which you would have
found had you Googled a little more, if it can help at all:

http://www.javahotchocolate.com/tutorials/subclipse.html
Re: Failed to Load JavaHL Library [message #675302 is a reply to message #675207] Tue, 31 May 2011 05:54 Go to previous messageGo to next message
thoufiq  is currently offline thoufiq Friend
Messages: 16
Registered: May 2011
Junior Member
Hello Russell,
Thanks a lot for your help. I have uninstalled and installed the subclipse plugins for many many times but still i cant found a svn perspective in the window > show perspective > other menu's. I don't know what is the cause for this. pls pls pls....help me.
Re: Failed to Load JavaHL Library [message #675518 is a reply to message #675302] Tue, 31 May 2011 17:56 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2406
Registered: July 2009
Senior Member
On 5/31/11 1:54 AM, thoufiq wrote:
> Hello Russell,
> Thanks a lot for your help. I have uninstalled and installed the
> subclipse plugins for many many times but still i cant found a svn
> perspective in the window > show perspective > other menu's. I don't
> know what is the cause for this. pls pls pls....help me.

Since Subclipse comes from a third-party, not eclispe.org, why don't you
ask that community for help with it.
Alternatively, install the Subversive plugin, which is distributed and
supported by Eclipse.org

Eric
Re: Failed to Load JavaHL Library [message #975652 is a reply to message #672497] Thu, 08 November 2012 02:00 Go to previous message
Seung-Un Ham is currently offline Seung-Un HamFriend
Messages: 1
Registered: November 2012
Junior Member
Just follow this.

http ://ok2pro.com/random/fixEclipseJavaHL.png
Previous Topic:Disabling the automatic building of non-selected projects?
Next Topic:Non-persistent way to "Open With -> System Editor"?
Goto Forum:
  


Current Time: Thu Dec 18 05:42:31 GMT 2014

Powered by FUDForum. Page generated in 0.02548 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software