Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » ajdt 1.4 and aspectrt.jar
ajdt 1.4 and aspectrt.jar [message #67207] Fri, 06 October 2006 21:45 Go to next message
Eugene Kuleshov is currently offline Eugene Kuleshov
Messages: 505
Registered: July 2009
Senior Member
Hi,

I just noticed that AJDT 1.4 release for Eclipse 3.2 does not allow to
replace aspectjrt.jar to 1.5.2a

Anyways, why does compiler have to use exactly the same version as it
will be used at runtime?

regards,
Eugene
Re: ajdt 1.4 and aspectrt.jar [message #67243 is a reply to message #67207] Mon, 09 October 2006 16:06 Go to previous message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
Eugene Kuleshov wrote:
> I just noticed that AJDT 1.4 release for Eclipse 3.2 does not allow to
> replace aspectjrt.jar to 1.5.2a
>
> Anyways, why does compiler have to use exactly the same version as it
> will be used at runtime?

Work is underway to improve things in this area:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=113948
This restructuring will allow for easier updating of AspectJ into AJDT.

--Matt
Re: ajdt 1.4 and aspectrt.jar [message #595018 is a reply to message #67207] Mon, 09 October 2006 16:06 Go to previous message
Matt Chapman is currently offline Matt Chapman
Messages: 429
Registered: July 2009
Senior Member
Eugene Kuleshov wrote:
> I just noticed that AJDT 1.4 release for Eclipse 3.2 does not allow to
> replace aspectjrt.jar to 1.5.2a
>
> Anyways, why does compiler have to use exactly the same version as it
> will be used at runtime?

Work is underway to improve things in this area:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=113948
This restructuring will allow for easier updating of AspectJ into AJDT.

--Matt
Previous Topic:How I can run a web project with aspectj capabilities
Next Topic:advices from aspectPath jars aren't shown in Cross References view
Goto Forum:
  


Current Time: Sat Oct 25 00:10:28 GMT 2014

Powered by FUDForum. Page generated in 0.06848 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software