Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [xpand, uml2] Support for RSA 8
[xpand, uml2] Support for RSA 8 [message #671539] Wed, 18 May 2011 09:00 Go to next message
Thomas Kriechbaum is currently offline Thomas KriechbaumFriend
Messages: 12
Registered: July 2009
Junior Member
Hello,

currently we are using oaw 4.3 to generate Java code from RSA 7 UML models. oaw4 provides a RSA-specific adpater (org.openarchitectureware.adapter.rsdp.workflow.RSASetup) that allows to read *.emx UML models directly.

Because RSA 8 updates UML models to UML2 3.0.0 (http://www.eclipse.org/uml2/3.0.0/UML; RSA 7.x uses UML2 2.1.x instead), the generation workflow based on oaw 4.3 dos not work anymore.

Is there a way to process RSA 8 UML models directly? I have read the UML2 Adapter tutorial. But I have not found any information about a RSA-specific adapter.

Have I missed some useful hint?

Are there any plans to support RSA models directly? I have found a statement in this forum that vendor specific adapters are not in focus (e.g. an adapter for Enterprise Architect). But exporting an RSA model to an UML2 model before starting my generation workflow would not be my preferred solution (now we are triggering the generation workflow within a maven build process - that's working great).

Thanks,
Thomas
Re: [xpand, uml2] Support for RSA 8 [message #671817 is a reply to message #671539] Thu, 19 May 2011 05:05 Go to previous messageGo to next message
Thomas Kriechbaum is currently offline Thomas KriechbaumFriend
Messages: 12
Registered: July 2009
Junior Member
I have found the the rsx4oaw plugin, that provides an adapter for Rational tools.

Does anyone of you have some experience with this plugin?

Thanks,
Thomas
Re: [xpand, uml2] Support for RSA 8 [message #671901 is a reply to message #671539] Thu, 19 May 2011 10:06 Go to previous messageGo to next message
Henri Walter is currently offline Henri WalterFriend
Messages: 1
Registered: May 2011
Junior Member
Hi Thomas,

I'm also confronted with the hurdles of migrating oaw 4.3 m2t for IBM Rational Software Architect Models. We additionally use custom UML2-profiles created with RSA.
Unfortunately, support for RSA (or RSA models) seems to be have no priority.
I still suffer difficulties to even get MWE support included into an RSA 8.0.2 installation.

Besides you, anybody out there who can help on setting up MWE inside RSA8.0
BTW: Using update sites is no longer any option for me - with some clicks and some updates its very easy to get the installation broken (startup issues, missing features issues due to version incompatibilities of the plugins)


Kind regards,

Henri Walter
Re: [xpand, uml2] Support for RSA 8 [message #672151 is a reply to message #671901] Fri, 20 May 2011 05:39 Go to previous message
Thomas Kriechbaum is currently offline Thomas KriechbaumFriend
Messages: 12
Registered: July 2009
Junior Member
Hello Henri,

we are also using custom UML2-profiles created within RSA.

Since we only use RSA for the modelling part the oaw-plugins are not required within RSA (our cartridge has been implemented via Eclipse). Furthermore the code generation is triggered by a maven build process using the Fornax maven plugin.

The migration from oaw4 to M2T is planned within the next 2 - 3 weeks. I will post my experiences in this topic.

Thomas
Previous Topic:[ACCELEO] fonction standard (fonction pr├ędefinis)
Next Topic:[XPand2] Call template within another project
Goto Forum:
  


Current Time: Mon Dec 22 12:04:07 GMT 2014

Powered by FUDForum. Page generated in 0.04745 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software