Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Error when setting up JAX-WS project
Error when setting up JAX-WS project [message #670320] Fri, 13 May 2011 14:01 Go to next message
oliver pike is currently offline oliver pikeFriend
Messages: 10
Registered: December 2010
Junior Member
I'm stepping through this tutorial: http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebService/bu_tutorial.html

I'm trying to select the axis2 Web Service facet (step 6) but I'm getting this error message in eclipse: "Axis2 Web Services Core 1.1 requires Dynamic Web Module with version matching expression "2.2,2.3,2.4,2.5"

http://i.stack.imgur.com/Ufpl6.png

I had downloaded and installed axis2 1.5.4 and then in eclipse I went into "windows->preferences->web services->axis2 preferences". Under the "axis2 runtime" tab I specified the axis2 location. The message "Axis2 runtime loaded successfully" appeared.

http://i.stack.imgur.com/e4NKs.png

I don't know why it says "Axis2 Web Services Core 1.1". Does eclipse wtp come bundled with axis2 1.1 or is there a separate version # for the axis core from the overall axis version #?
Re: Error when setting up JAX-WS project [message #671010 is a reply to message #670320] Mon, 16 May 2011 14:14 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2333
Registered: July 2009
Senior Member
I expect most of those messages in the first dialog are about the facet versions shown there. Which facets and versions do you see selected when you expand the "Axis2 Web Services" node?

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Error when setting up JAX-WS project [message #671150 is a reply to message #670320] Mon, 16 May 2011 22:00 Go to previous message
ekim  is currently offline ekim Friend
Messages: 12
Registered: October 2009
Junior Member
Look at what version of WTP you are using, I would think a more recent version which would by default use a more recent 'Dynamic Web Module' - such as 3.0

First, the tutorial you linked to is very out of date. Try this link for an updated version: http://wiki.eclipse.org/Creating_a_bottom-up_Axis2_Web_servi ce

It is essentially the same with updates. Having said that even it is somewhat dated as is Axis2 (might try CXF).

You should see new content at step 5 referring to the your version of WTP. Also note the 'Dynamic Web Module' setting in the dialogue which you may have to set back to 2.5 from 3.0

I think this will help,


-mike
Previous Topic:How to install only the Eclipse XML Editors and Tools?
Next Topic:Editor code templates
Goto Forum:
  


Current Time: Mon Nov 24 09:36:37 GMT 2014

Powered by FUDForum. Page generated in 0.04710 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software