Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Moving .eclipse folder(How can I move the .eclipse folder from user.home?)
Moving .eclipse folder [message #670263] Fri, 13 May 2011 06:08 Go to next message
Rajnish Bhaskar is currently offline Rajnish Bhaskar
Messages: 4
Registered: July 2009
Junior Member
Hi,
I've recently been moved to a managed (Windows 7-based) desktop at work, with a roaming profile. However, my roaming profile isn't synchronising properly because a file in my .eclipse folder in %USERPROFILE% has too long a filename (ie nested too deeply) for the server to cope with.

My IT bods are reluctant to modify group policy to specifically exclude the .eclipse, so is there any way I can move it out somewhere else?

I've tried adding these lines to my eclipse.ini but not had any luck:

-configuration 
h:/.eclipse/org.eclipse.platform_3.6.1_248562372/
-user
h:/.eclipse


Any suggestions?
Re: Moving .eclipse folder [message #670289 is a reply to message #670263] Fri, 13 May 2011 07:48 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Setting the -configuration flag is probably the correct thing to do. See Multi-User Installs [1] about setting the private configuration area location and Runtime Options [2] which specifies the runtime options and their mapping to system properties.

Did you start up your eclipse with the new configuration area when it was empty? Or did you copy your .eclipse folder over (which might not work well)?

AFAIK the configuration area only needs to have the appropriate config directory with a one line config.ini. ex:

my .eclipse/org.eclipse.platform_3.6.1_1664091916/configuration /config.ini contains:

osgi.sharedConfiguration.area=file\:configuration/


PW

[1] http://help.eclipse.org/helios/index.jsp?topic=/org.eclipse. platform.doc.isv/reference/misc/multi_user_installs.html

[2] http://help.eclipse.org/helios/index.jsp?topic=/org.eclipse. platform.doc.isv/reference/misc/runtime-options.html


Re: Moving .eclipse folder [message #670374 is a reply to message #670289] Fri, 13 May 2011 13:40 Go to previous messageGo to next message
Rajnish Bhaskar is currently offline Rajnish Bhaskar
Messages: 4
Registered: July 2009
Junior Member
Paul Webster wrote on Fri, 13 May 2011 07:48
Setting the -configuration flag is probably the correct thing to do. See Multi-User Installs [1] about setting the private configuration area location and Runtime Options [2] which specifies the runtime options and their mapping to system properties.

Did you start up your eclipse with the new configuration area when it was empty? Or did you copy your .eclipse folder over (which might not work well)?


I moved the .eclipse folder to the new location (in my case H:\). Would it work to delete the .eclipse in %USERPROFILE%, modify eclipse.ini and let Eclipse create a new .eclipse directory in the new location, before copying everything else back over?

Paul Webster wrote on Fri, 13 May 2011 07:48
AFAIK the configuration area only needs to have the appropriate config directory with a one line config.ini. ex:

my .eclipse/org.eclipse.platform_3.6.1_1664091916/configuration /config.ini contains:

osgi.sharedConfiguration.area=file\:configuration/



I'm not sure what you're suggesting here.
Re: Moving .eclipse folder [message #670377 is a reply to message #670374] Fri, 13 May 2011 13:51 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

I guess what I would try:

1) what if you use -configuration h:/.eclipse/org.eclipse.platform_3.6.1_248562372/configurati on ?

2) move your $HOME/.eclipse to somewhere safe for now, like eclipse.bak

3) delete your H:\.eclipse. Try and start eclipse while pointing to that location.

If #3 works you are set. If not, try #4

4) make sure the only thing in your H:\.eclipse\org.eclipse.platform_3.6.1_248562372\configurati on is a config.ini with the shared area property.

Then use -configuration h:/.eclipse/org.eclipse.platform_3.6.1_248562372/configurati on

PW


Re: Moving .eclipse folder [message #670404 is a reply to message #670377] Fri, 13 May 2011 17:49 Go to previous messageGo to next message
Rajnish Bhaskar is currently offline Rajnish Bhaskar
Messages: 4
Registered: July 2009
Junior Member
Thanks for that. I'll give it a try on Monday and report back.
Re: Moving .eclipse folder [message #671060 is a reply to message #670404] Mon, 16 May 2011 12:13 Go to previous message
Rajnish Bhaskar is currently offline Rajnish Bhaskar
Messages: 4
Registered: July 2009
Junior Member
No luck here, I fear. To be clear, what I mean by 'no luck' is that when I make my config changes and restart Eclipse, it just recreates a .eclipse directory in $HOME and asks me where to put my workspace, rather than just finding it. Any more ideas?
Previous Topic:Released Plugin not visible in Eclipse Plugin Installer
Next Topic:Preference page
Goto Forum:
  


Current Time: Fri Aug 29 08:31:35 EDT 2014

Powered by FUDForum. Page generated in 0.01681 seconds