Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » authentication fails after password change
authentication fails after password change [message #669364] Tue, 10 May 2011 05:43 Go to next message
Henrik Rentz-Reichert is currently offline Henrik Rentz-ReichertFriend
Messages: 220
Registered: July 2009
Senior Member
Hi,

I'm using Eclipse's secure storage and this worked fine until eclipse.org forced me to change my password.
Now accessing my git repository aborts with
An internal Exception occured during push: https://git.eclipse.org/gitroot/etrice/org.eclipse.etrice.gi t: not authorized

I would expect a prompt for correct credentials in this case.

Also I wasn't able to change the password in the secure storage.

How can I tell EGit to use my new password?

Thanks,
Henrik
Re: authentication fails after password change [message #673230 is a reply to message #669364] Sun, 22 May 2011 23:28 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 612
Registered: July 2009
Senior Member
Yeah, this shouldn't raise an ugly error but prompt for credentials, please file a bug here [1].

In order to change credentials try the following:
Open Git repositories view, open "Remotes > origin > <your push url>" and click "Change Credentials..."

[1] https://bugs.eclipse.org/bugs/enter_bug.cgi?product=EGit
Re: authentication fails after password change [message #736150 is a reply to message #673230] Thu, 13 October 2011 16:54 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 5587
Registered: July 2009
Senior Member
Am 23.05.2011 01:28, schrieb Matthias Sohn:
> Yeah, this shouldn't raise an ugly error but prompt for credentials, please file a bug here [1].
Has a bug been filed? I'm experiencing the same problem ;-(

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Re: authentication fails after password change [message #1418896 is a reply to message #736150] Sun, 07 September 2014 20:59 Go to previous messageGo to next message
Ajit Dingankar is currently offline Ajit DingankarFriend
Messages: 4
Registered: July 2011
Junior Member
I had the same problem (after all the years Wink so I filed a bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=443471
Using the workaround suggested by Matthias Sohn in the meanwhile;
thanks, Matthias!

Regards,
Ajit
====

Re: authentication fails after password change [message #1419911 is a reply to message #1418896] Tue, 09 September 2014 08:37 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 612
Registered: July 2009
Senior Member
which EGit version are you using ?
Previous Topic:Configure... dialog for fetch shows wrong remote
Next Topic:Custom merge commit message
Goto Forum:
  


Current Time: Thu Dec 18 23:16:50 GMT 2014

Powered by FUDForum. Page generated in 0.12314 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software