Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » JavaServer Faces » Conflicting dependencies with Liferay IDE(Help needed to install Liferay IDE on Helios with JSF)
Conflicting dependencies with Liferay IDE [message #668608] Fri, 06 May 2011 12:11 Go to next message
Chris Rowse is currently offline Chris RowseFriend
Messages: 1
Registered: May 2011
Junior Member
Not sure if this is the correct forum, the messages relate to JSF, please no flames.

I am having problems loading Liferay IDE onto my existing Helios (which is up to date).
The messages are reasonable clear except.

a) What do I need to uninstall?
b) How do I uninstall a package?

Thanks in advance
Chris

Cannot complete the install because of a conflicting dependency.
  Software being installed: Liferay IDE 1.2.3.v201103310212 (com.liferay.ide.eclipse.tools.feature.group 1.2.3.v201103310212)
  Software currently installed: Shared profile 1.0.0.1276788056866 (SharedProfile_epp.package.jee 1.0.0.1276788056866)
  Only one of the following can be installed at once: 
    JavaServer Faces Tools - Core 1.3.2.v20100906-p001 (org.eclipse.jst.jsf.core 1.3.2.v20100906-p001)
    JavaServer Faces Tools - Core 1.3.1.v20100712 (org.eclipse.jst.jsf.core 1.3.1.v20100712)
    JavaServer Faces Tools - Core 1.3.2.v20100906 (org.eclipse.jst.jsf.core 1.3.2.v20100906)
    JavaServer Faces Tools - Core 1.3.0.v20100602 (org.eclipse.jst.jsf.core 1.3.0.v20100602)
    JavaServer Faces Tools - Core 1.3.0.v20100602-p001 (org.eclipse.jst.jsf.core 1.3.0.v20100602-p001)
    JavaServer Faces Tools - Core 1.3.3.v201102021253 (org.eclipse.jst.jsf.core 1.3.3.v201102021253)
  Cannot satisfy dependency:
    From: Shared profile 1.0.0.1276788056866 (SharedProfile_epp.package.jee 1.0.0.1276788056866)
    To: org.eclipse.jst.jsf.core [1.3.0.v20100602]
  Cannot satisfy dependency:
    From: Liferay JSF UI 1.2.3.v201103310212 (com.liferay.ide.eclipse.portlet.jsf.core 1.2.3.v201103310212)
    To: bundle org.eclipse.jst.jsf.core 1.3.2
  Cannot satisfy dependency:
    From: Liferay IDE 1.2.3.v201103310212 (com.liferay.ide.eclipse.tools.feature.group 1.2.3.v201103310212)
    To: com.liferay.ide.eclipse.portlet.jsf.core [1.2.3.v201103310212]
Re: Conflicting dependencies with Liferay IDE [message #669825 is a reply to message #668608] Wed, 11 May 2011 17:34 Go to previous message
Ian Trimble is currently offline Ian TrimbleFriend
Messages: 137
Registered: July 2009
Senior Member
From the messages, it looks like Liferay IDE bundles its own version of JSF Tools (or even all of WTP), you have a newer version in your installation, and Liferay isn't going to work with that newer version. First thing I would do is to check Liferay IDE docs to see what configurations it supports.
Previous Topic:Customizing palette in WPE
Next Topic:newbie,
Goto Forum:
  


Current Time: Mon Dec 22 14:59:15 GMT 2014

Powered by FUDForum. Page generated in 0.01886 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software