Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » IWorkbenchAdapter not registered correctly(No decorations available in BasicNewFileResourceWizard)
icon4.gif  IWorkbenchAdapter not registered correctly [message #668211] Wed, 04 May 2011 10:03 Go to next message
Chris
Messages: 12
Registered: September 2009
Location: Braunschweig
Junior Member
I am using the BasicNewFileResourceWizard in an rcp application. The tree showing the workspace resources does not show icons or labels of resources.

I found out that the factory needed to create the IWorkbenchAdapter does not return anything. That seems to be because the AdapterManager has the type org.eclipse.core.resources.mapping.ResourceMapping registered with the class org.eclipse.core.internal.resources.Project instead of the IWorkbenchAdapter.

a) How can I find out when that ResourceMapping is registered with Project instead of the IWorkbenchAdapter?

b) I tried adding a factory entry in the extension org.eclipse.core.runtime.adapters and alternatively invoke Platform.getAdapterManager().registerAdapters to register the correct class. These attempts were not successful.

A hint into the correct direction would be very helpful.
Re: IWorkbenchAdapter not registered correctly [message #668238 is a reply to message #668211] Wed, 04 May 2011 11:35 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

On 05/04/2011 10:03 AM, Chris wrote:
> A hint into the correct direction would be very helpful.

To work with IWorkbenchAdapter you need to call
org.eclipse.ui.ide.IDE.registerAdapters() in your application's
WorkbenchAdvisor, usually in the initialize(*) method.

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Platform_Expression_Framework
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/helios/index.jsp?topic=/org.eclipse. platform.doc.isv/guide/workbench.htm


Re: IWorkbenchAdapter not registered correctly [message #668244 is a reply to message #668238] Wed, 04 May 2011 11:57 Go to previous message
Chris
Messages: 12
Registered: September 2009
Location: Braunschweig
Junior Member
Wonderful - it worked right away!

Thank you very much!
Previous Topic:Equinox launcher: not working on Mac OS 10.4 Tiger?
Next Topic:CNF: Remove SOME popup options from the ones that are platform contributions
Goto Forum:
  


Current Time: Thu Jul 24 23:52:13 EDT 2014

Powered by FUDForum. Page generated in 0.03501 seconds