Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Eclipse doesn't honor AnnotationSpecification
Eclipse doesn't honor AnnotationSpecification [message #667898] Mon, 02 May 2011 16:24 Go to next message
Aivar Annamaa is currently offline Aivar Annamaa
Messages: 32
Registered: July 2009
Member
I have some custom markers together with AnnotationSpecification, where I have specified that "overviewRulerPreferenceValue=false".
In "Annotations" preference page "Show in overview ruler" checkbox is unchecked for that kind of annotations.

Yet, those markers create small boxes in overview ruler. Curiously, when I set "overviewRulerPreferenceValue=true", then those boxes become much lighter (border is removed), but they are still visible in overview ruler.

How can I get rid of these small things in overview ruler?

Eclipse version is 3.6
Re: Eclipse doesn't honor AnnotationSpecification [message #667965 is a reply to message #667898] Tue, 03 May 2011 06:06 Go to previous messageGo to next message
Dani Megert is currently offline Dani Megert
Messages: 3801
Registered: July 2009
Senior Member
On 02.05.2011 18:24, Aivar Annamaa wrote:
> I have some custom markers together with AnnotationSpecification,
> where I have specified that "overviewRulerPreferenceValue=false".
> In "Annotations" preference page "Show in overview ruler" checkbox is
> unchecked for that kind of annotations.
>
> Yet, those markers create small boxes in overview ruler. Curiously,
> when I set "overviewRulerPreferenceValue=true", then those boxes
> become much lighter (border is removed), but they are still visible in
> overview ruler.
>
> How can I get rid of these small things in overview ruler?
You must make something wrong. When I use Eclipse SDK 3.6 and change
that preference for any annotation it works as expected for me.

Dani
>
> Eclipse version is 3.6
Re: Eclipse doesn't honor AnnotationSpecification [message #668075 is a reply to message #667965] Tue, 03 May 2011 15:46 Go to previous message
Aivar Annamaa is currently offline Aivar Annamaa
Messages: 32
Registered: July 2009
Member
I found the source of the problem:

in the definition of "org.eclipse.ui.editors.annotationTypes" I had "super" attribute with value "org.eclipse.ui.workbench.texteditor.info".

When I removed this attribute, then those little boxes also disappeared.
Previous Topic:Why can't I use any update sites with 3.6.2 on Windows Vista
Next Topic:My Plugin only works in helios!!
Goto Forum:
  


Current Time: Sat Nov 01 11:20:37 GMT 2014

Powered by FUDForum. Page generated in 0.04699 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software