Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Problem with dependencies for Ada 2005 Code Generation add-in
Problem with dependencies for Ada 2005 Code Generation add-in [message #667834] Mon, 02 May 2011 12:08 Go to next message
Piotr Trojanek is currently offline Piotr Trojanek
Messages: 7
Registered: October 2010
Junior Member
Hi all,

I have faced the following issue when trying to add the Ada 2005 Code Generation add-in into a vanilla Papyrus-1.12.3 installation (Linux, 32bit, latest "official" 1.6.0_24 Java):
  Cannot connect to keystore.
  This trust engine is read only.
  Cannot complete the install because one or more required items could not be found.
    Software currently installed: ADA 2005 code generator for Papyrus 1.0.1.200911231214 (com.adacore.uml2ada2005_feature.feature.group 1.0.1.200911231214)
    Missing requirement: com.adacore.uml2ada2005 1.0.1.200911231214 (com.adacore.uml2ada2005 1.0.1.200911231214) requires 'bundle com.cea.papyrus.integration.acceleo 1.2.0' but it could not be found
    Cannot satisfy dependency:
      From: ADA 2005 code generator for Papyrus 1.0.1.200911231214 (com.adacore.uml2ada2005_feature.feature.group 1.0.1.200911231214)
      To: com.adacore.uml2ada2005 [1.0.1.200911231214]


I think, that keystore is not a problem here. I have also both the CDT Gallileo and the Acceleo update site configured, as suggested on the Add-ins donwload site. I would expect, that if the dependencies are possible to satisfy, the update manager would just pick them.

I was also trying to install manually the "Acceleo integration plugin for Papyrus" plugin in, but this fails with the another missing dependency:
  Cannot connect to keystore.
  This trust engine is read only.
  Cannot complete the install because one or more required items could not be found.
    Software currently installed: Acceleo integration plugin for Papyrus 1.2.0 (com.cea.papyrus.integration.acceleo.feature.group 1.2.0)
    Missing requirement: Acceleo integration inside Papyrus 1.2.0 (com.cea.papyrus.integration.acceleo 1.2.0) requires 'bundle fr.obeo.acceleo.chain 0.0.0' but it could not be found
    Cannot satisfy dependency:
      From: Acceleo integration plugin for Papyrus 1.2.0 (com.cea.papyrus.integration.acceleo.feature.group 1.2.0)
      To: com.cea.papyrus.integration.acceleo [1.2.0]


Am I missing something?

Thanks in advance! Piotr.
Re: Problem with dependencies for Ada 2005 Code Generation add-in [message #667934 is a reply to message #667834] Mon, 02 May 2011 20:03 Go to previous messageGo to next message
Piotr Trojanek is currently offline Piotr Trojanek
Messages: 7
Registered: October 2010
Junior Member
I have solved my own issue by manually installing the Ada 2005 Code Generator in the following items:

  1. Acceleo solution from an Acceleo update site,
  2. Acceleo required dependencies from the Papyrus Add-ins update site
  3. and finally the Ada 2005 Code Generator from the Papyrus Add-ins update site.

The code generator is working, but I am not able to apply the HiUML profile to my model as described in the "Apply_a_static_profile" section of the Papyrus User Guide Sad
The HiUML option is available to pick up, but after selecting is does not show on the list of the applied profiles.

I appreciate any ideas how to get this to work...

Thanks, Piotr.

[Updated on: Mon, 02 May 2011 20:03]

Report message to a moderator

Re: Problem with dependencies for Ada 2005 Code Generation add-in [message #673308 is a reply to message #667934] Mon, 23 May 2011 08:03 Go to previous messageGo to next message
Patrick Tessier is currently offline Patrick Tessier
Messages: 142
Registered: July 2009
Senior Member
Hum...
I will verified why this functionality was not maintained...
Patrick
Papyrus team
Re: Problem with dependencies for Ada 2005 Code Generation add-in [message #673312 is a reply to message #673308] Mon, 23 May 2011 08:14 Go to previous messageGo to next message
Patrick Tessier is currently offline Patrick Tessier
Messages: 142
Registered: July 2009
Senior Member
This plugin is not in the version papyrus MDT. I think that you taken this feature form papyrus 1.X.
If you have done a patch to connect ada, you can send us this ;D
Patrick
Papyrus team
Re: Problem with dependencies for Ada 2005 Code Generation add-in [message #757697 is a reply to message #667834] Mon, 21 November 2011 09:41 Go to previous message
Alejandro  is currently offline Alejandro
Messages: 3
Registered: November 2011
Junior Member
Piotr Trojanek wrote on Mon, 02 May 2011 08:08
Hi all,

I have faced the following issue when trying to add the Ada 2005 Code Generation add-in into a vanilla Papyrus-1.12.3 installation (Linux, 32bit, latest "official" 1.6.0_24 Java):
  Cannot connect to keystore.
  This trust engine is read only.
  Cannot complete the install because one or more required items could not be found.
    Software currently installed: ADA 2005 code generator for Papyrus 1.0.1.200911231214 (com.adacore.uml2ada2005_feature.feature.group 1.0.1.200911231214)
    Missing requirement: com.adacore.uml2ada2005 1.0.1.200911231214 (com.adacore.uml2ada2005 1.0.1.200911231214) requires 'bundle com.cea.papyrus.integration.acceleo 1.2.0' but it could not be found
    Cannot satisfy dependency:
      From: ADA 2005 code generator for Papyrus 1.0.1.200911231214 (com.adacore.uml2ada2005_feature.feature.group 1.0.1.200911231214)
      To: com.adacore.uml2ada2005 [1.0.1.200911231214]


I think, that keystore is not a problem here. I have also both the CDT Gallileo and the Acceleo update site configured, as suggested on the Add-ins donwload site. I would expect, that if the dependencies are possible to satisfy, the update manager would just pick them.

I was also trying to install manually the "Acceleo integration plugin for Papyrus" plugin in, but this fails with the another missing dependency:
  Cannot connect to keystore.
  This trust engine is read only.
  Cannot complete the install because one or more required items could not be found.
    Software currently installed: Acceleo integration plugin for Papyrus 1.2.0 (com.cea.papyrus.integration.acceleo.feature.group 1.2.0)
    Missing requirement: Acceleo integration inside Papyrus 1.2.0 (com.cea.papyrus.integration.acceleo 1.2.0) requires 'bundle fr.obeo.acceleo.chain 0.0.0' but it could not be found
    Cannot satisfy dependency:
      From: Acceleo integration plugin for Papyrus 1.2.0 (com.cea.papyrus.integration.acceleo.feature.group 1.2.0)
      To: com.cea.papyrus.integration.acceleo [1.2.0]


Am I missing something?

Thanks in advance! Piotr.


I have the same problem. I have been trying to install it in Eclipse Galileo and Indigo, but in both of them, i get the same message.

is Ada 2005 code generation still working now? How can i resolve this problem to install it?

Thanks!
Previous Topic:How to create a new valueType?
Next Topic:Load resuorce
Goto Forum:
  


Current Time: Fri Oct 31 10:55:04 GMT 2014

Powered by FUDForum. Page generated in 0.02338 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software