Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Equinox launcher: not working on Mac OS 10.4 Tiger?
Equinox launcher: not working on Mac OS 10.4 Tiger? [message #667832] Mon, 02 May 2011 07:54 Go to next message
J.-P. Pellet is currently offline J.-P. Pellet
Messages: 71
Registered: July 2009
Member
I've had complains of clients that my RCP app won't launch on Mac OS
10.4 Tiger, even though they have a working install of Java 5. It seems
the launcher itself displays a message that it needs at least 10.5. It
is true (I have no access to a 10.4 machine), and if so, is there a way
around it?

Cheers,
J.-P.
Re: Equinox launcher: not working on Mac OS 10.4 Tiger? [message #667869 is a reply to message #667832] Mon, 02 May 2011 10:02 Go to previous messageGo to next message
Grant Gayed is currently offline Grant Gayed
Messages: 2148
Registered: July 2009
Senior Member
I think the Carbon-based Eclipse/SWT should work on OS X 10.4. The
Cocoa-based Eclipse/SWT will definitely not run on OS X versions earlier
than 10.5, no reasonable workarounds available.

Grant


"J.-P. Pellet" <jpp-mac@gmx.net> wrote in message
news:ipm5im$pvd$2@news.eclipse.org...
> I've had complains of clients that my RCP app won't launch on Mac OS 10.4
> Tiger, even though they have a working install of Java 5. It seems the
> launcher itself displays a message that it needs at least 10.5. It is true
> (I have no access to a 10.4 machine), and if so, is there a way around it?
>
> Cheers,
> J.-P.
Re: Equinox launcher: not working on Mac OS 10.4 Tiger? [message #667986 is a reply to message #667869] Tue, 03 May 2011 04:37 Go to previous messageGo to next message
J.-P. Pellet is currently offline J.-P. Pellet
Messages: 71
Registered: July 2009
Member
Thanks for the information, Grant. Is it a limitation of the launcher or
of Cocoa SWT, too? Does this definitely mean I have to create two
separate builds — one in Carbon for 10.4 and one in Cocoa for 10.5 and 10.6?

Cheers,
J.-P.

On 02.05.11 16:02, Grant Gayed wrote:
> I think the Carbon-based Eclipse/SWT should work on OS X 10.4. The
> Cocoa-based Eclipse/SWT will definitely not run on OS X versions earlier
> than 10.5, no reasonable workarounds available.
>
> Grant
Re: Equinox launcher: not working on Mac OS 10.4 Tiger? [message #668046 is a reply to message #667986] Tue, 03 May 2011 09:58 Go to previous messageGo to next message
Grant Gayed is currently offline Grant Gayed
Messages: 2148
Registered: July 2009
Senior Member
SWT's Cocoa implementation uses a lot native API that is only available in
10.5 and newer. The launcher just does the OS version check to give advance
warning of this. If supporting OS X 10.4 is important then you'll
definitely need a version of your app that uses Carbon-based SWT/Eclipse
under the covers.

Grant


"J.-P. Pellet" <jpp-mac@gmx.net> wrote in message
news:ipoect$7qv$1@news.eclipse.org...
> Thanks for the information, Grant. Is it a limitation of the launcher or
> of Cocoa SWT, too? Does this definitely mean I have to create two separate
> builds
Re: Equinox launcher: not working on Mac OS 10.4 Tiger? [message #668165 is a reply to message #668046] Wed, 04 May 2011 05:00 Go to previous message
J.-P. Pellet is currently offline J.-P. Pellet
Messages: 71
Registered: July 2009
Member
Thanks a lot for the explanations!

Cheers,
J.-P.
Previous Topic:RCP with an Intro template
Next Topic:IWorkbenchAdapter not registered correctly
Goto Forum:
  


Current Time: Fri Apr 18 04:08:44 EDT 2014

Powered by FUDForum. Page generated in 0.03418 seconds