Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Problem with updating the plugin created by me
Problem with updating the plugin created by me [message #667322] Thu, 28 April 2011 04:57 Go to next message
bunta Choudhary is currently offline bunta ChoudharyFriend
Messages: 39
Registered: December 2010
Member
I have a Plug-in named myPlugin-1.1.0 (1.1.0 is the version number).
I installed that plugin in my eclipse through update manager.

Now, I modified few things and now I have a plugin named myPlugin-1.1.1. When I try to install the plugin through update manager in the same eclipse Helios it shows the message that plugin is already available so it will just update the plugin(what actually I want), but after doing the process nothing get changed not even the plugin version.

So what is the actual feasible way to create such type of update plugin.
Re: Problem with updating the plugin created by me [message #667381 is a reply to message #667322] Thu, 28 April 2011 12:41 Go to previous messageGo to next message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

When you installed plugin-1.1.0 what feature did you use. When you
created plugin-1.1.1 did you update the feature as well? Is it a top
level feature, or a feature included by a product definition?

PW


--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Platform_Expression_Framework
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/helios/index.jsp?topic=/org.eclipse. platform.doc.isv/guide/workbench.htm


Re: Problem with updating the plugin created by me [message #667484 is a reply to message #667381] Fri, 29 April 2011 03:43 Go to previous messageGo to next message
bunta Choudhary is currently offline bunta ChoudharyFriend
Messages: 39
Registered: December 2010
Member
for plugin myPlugin-1.1.0, I made a Feature project named myFeature and added this plugin myplugin-1.1.0.
Again on next update, I deleted the 1.1.0 and added my entry of 1.1.1 and then created a new update site.

Even the scenario is not getting updated
Re: Problem with updating the plugin created by me [message #667533 is a reply to message #667484] Fri, 29 April 2011 12:01 Go to previous message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

On 04/28/2011 11:43 PM, buntha wrote:
> for plugin myPlugin-1.1.0, I made a Feature project named myFeature and
> added this plugin myplugin-1.1.0.
> Again on next update, I deleted the 1.1.0 and added my entry of 1.1.1
> and then created a new update site.

I assume that's "I deleted the 1.1.0 feature and added the 1.1.1
feature", right?

could you run the director listing on your 1.1.0 update site, and then
on the 1.1.1 update site, and post those results?

ex:
eclipse/eclipse -noSplash -application org.eclipse.equinox.p2.director
-repository file:///path/to/your/update/site -list

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Platform_Expression_Framework
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/helios/index.jsp?topic=/org.eclipse. platform.doc.isv/guide/workbench.htm


Previous Topic:Mouse listener on tab item of a workbench part
Next Topic:Help not too helpful
Goto Forum:
  


Current Time: Thu Dec 18 08:44:53 GMT 2014

Powered by FUDForum. Page generated in 0.01872 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software