Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » BPEL Designer » namespaces in bpel
namespaces in bpel [message #5933] Fri, 08 September 2006 09:08 Go to next message
brujito is currently offline brujito
Messages: 6
Registered: July 2009
Junior Member
Hi,

I'm trying to get all namespaces declared in bpel process, but I
couldn't find any accessor method. When I've finally tried to get underlying
dom element I've got null instead:

if (getProcess().getElement() == null) {
getProcess().updateElement(false);
}
Element element = getProcess().getElement();
// element == null

Am I doing something wrong?
--
Rykovanov Dmitri
mailto:drykovan@abisoft.spb.ru
Re: namespaces in bpel [message #6006 is a reply to message #5933] Thu, 28 September 2006 21:00 Go to previous message
Michal Chmielewski is currently offline Michal Chmielewski
Messages: 58
Registered: July 2009
Member
Dmitrii,

You probably had figured this by now, but just in case you did not ...

.... the model API does not yet facade the XML DOM, so getElement() will
always return null.

This is one of the things TO DO on the plate.

The place to do get this right now is the BPELResource class in
....model.resource.BPELResource

-michal

Rykovanov Dmitrii wrote:
> Hi,
>
> I'm trying to get all namespaces declared in bpel process, but I
> couldn't find any accessor method. When I've finally tried to get underlying
> dom element I've got null instead:
>
> if (getProcess().getElement() == null) {
> getProcess().updateElement(false);
> }
> Element element = getProcess().getElement();
> // element == null
>
> Am I doing something wrong?
> --
> Rykovanov Dmitri
> mailto:drykovan@abisoft.spb.ru
>
>
Previous Topic:The very begining fails
Next Topic:Create process from template flashes
Goto Forum:
  


Current Time: Fri Oct 24 15:00:29 GMT 2014

Powered by FUDForum. Page generated in 0.01833 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software