Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Rhino debugging in Helios - What am I missing?
Rhino debugging in Helios - What am I missing? [message #665709] Fri, 15 April 2011 15:00 Go to next message
Jim Garrison is currently offline Jim Garrison
Messages: 57
Registered: July 2009
Member
I have searched the web for several hours and cannot find a couple of key pieces of information that would let me use JSDT in Helios. I've seen all the pages describing how to set things up but am not able to actually get my Javascript to launch. Here's what I've done

I have launched the Rhino DebugShell in a command window as
java -cp "c:/dev/tools/rhino/js.jar;org.eclipse.wst.jsdt.debug.rhino.debugger_1.0.1.v201008170101.jar" org.eclipse.wst.jsdt.debug.rhino.debugger.shell.DebugShell -port 9000 -suspend y -trace true


I have launched the Rhino debug connector in Eclipse 3.6 SR2.

What I can't find is how to launch my Javascript in the debug shell. I tried passing its full path on the command line but that did nothing.

Can someone point me to where this is described?

Also, I can't seem to find a way to terminate the DebugShell other than killing the process with Task Manager.
Re: Rhino debugging in Helios - What am I missing? [message #665758 is a reply to message #665709] Fri, 15 April 2011 18:45 Go to previous messageGo to next message
Jim Garrison is currently offline Jim Garrison
Messages: 57
Registered: July 2009
Member
I got past the issues described above. I'd like to delete this post but there doesn't seem to be a "delete" option.
Re: Rhino debugging in Helios - What am I missing? [message #665893 is a reply to message #665758] Mon, 18 April 2011 04:26 Go to previous messageGo to next message
Syam Missing name is currently offline Syam Missing name
Messages: 6
Registered: April 2011
Junior Member
Instead provide the resolution steps.
Re: Rhino debugging in Helios - What am I missing? [message #879913 is a reply to message #665709] Fri, 01 June 2012 05:36 Go to previous message
abc 33887 is currently offline abc 33887
Messages: 1
Registered: June 2012
Junior Member
I have the same issue. Can you please provide your solution?
Previous Topic:XML multipage editor cutomization (GEF, design and source)
Next Topic:Cannot edit html files with Web Page Editor - HTML Editor
Goto Forum:
  


Current Time: Sat Oct 25 15:16:44 GMT 2014

Powered by FUDForum. Page generated in 0.05937 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software