Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Maximizing a Part
Maximizing a Part [message #664338] Fri, 08 April 2011 12:39 Go to next message
Christoph Keimel is currently offline Christoph Keimel
Messages: 353
Registered: December 2010
Location: Germany
Senior Member
Hello,

having added the MinMaxAddon ... how can I add the "Maximize"-Button to a PartStack. At the moment I only have the Minimize-Button.

I'm using the standalone e4 Workbenchmodel without forward, backward compatibility.

Regards,
Christoph
Re: Maximizing a Part [message #664978 is a reply to message #664338] Tue, 12 April 2011 16:33 Go to previous messageGo to next message
Remy Suen is currently offline Remy Suen
Messages: 462
Registered: July 2009
Senior Member
Christoph Keimel wrote on Fri, 08 April 2011 08:39
having added the MinMaxAddon ... how can I add the "Maximize"-Button to a PartStack. At the moment I only have the Minimize-Button.
We only added that recently. If you're using 4.1M6 you won't have that feature I don't think.
Re: Maximizing a Part [message #665104 is a reply to message #664978] Wed, 13 April 2011 09:41 Go to previous messageGo to next message
Christoph Keimel is currently offline Christoph Keimel
Messages: 353
Registered: December 2010
Location: Germany
Senior Member
I'm using the indigo 3.7.0 release for development. The e4 plug-ins are in the Target Definition and I try to keep up to date with the builds. Right now I have 0.9.1.v20110331-2030 of the org.eclipse.e4.ui.workbench and *.renderers.swt plug-ins.

Re: Maximizing a Part [message #665461 is a reply to message #665104] Thu, 14 April 2011 16:52 Go to previous messageGo to next message
Remy Suen is currently offline Remy Suen
Messages: 462
Registered: July 2009
Senior Member
Christoph Keimel wrote on Wed, 13 April 2011 05:41
Right now I have 0.9.1.v20110331-2030 of the org.eclipse.e4.ui.workbench and *.renderers.swt plug-ins.
That should be okay. There may be a bug or something. You might also want to try clearing out your target workspace.
Re: Maximizing a Part [message #665640 is a reply to message #665461] Fri, 15 April 2011 10:51 Go to previous messageGo to next message
Christoph Keimel is currently offline Christoph Keimel
Messages: 353
Registered: December 2010
Location: Germany
Senior Member
Hi Remy,

I have already tried that (by activating "Clear: workspace" in the run configuration). I have built a small sample project to show the problem. It sounds like this might be a bug, so I have filed it (including the testcase project):

Bug 342947

Regards,
Christoph
Re: Maximizing a Part [message #666402 is a reply to message #665640] Wed, 20 April 2011 10:37 Go to previous messageGo to next message
Christoph Keimel is currently offline Christoph Keimel
Messages: 353
Registered: December 2010
Location: Germany
Senior Member
Hello,

following the discussion in Bug 342947 I have checked out the current plug-in from HEAD. I initially got some NullPointerExceptions because I have no "EDITOR_AREA" defined.

It seems to me, that it is necessary to define an Element with the ID set ID_EDITOR_AREA. What is this for and how does it work?

Thanks,
Christoph

P.S. If I modify the code to not use the EDITOR_AREA by check for null, the maximize button will just switch to Restore-Mode without maximizing the PartStack.

Changes:
MinMaxAddon_changes.pdf

[Updated on: Wed, 20 April 2011 10:41]

Report message to a moderator

Re: Maximizing a Part [message #666410 is a reply to message #666402] Wed, 20 April 2011 10:55 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5330
Registered: July 2009
Senior Member
Well this looks for me like a bug then. You should not be forced to have
an EDITOR_AREA!

Please add a remark on the bug about this.

Tom

Am 20.04.11 12:37, schrieb Christoph Keimel:
> Hello,
>
> following the discussion in Bug 342947 I have checked out the current
> plug-in from HEAD. I initially got some NullPointerExceptions because I
> have no "EDITOR_AREA" defined.
> It seems to me, that it is necessary to define an Element with the ID
> set ID_EDITOR_AREA. What is this for and how does it work?
>
> Thanks,
> Christoph
>
> P.S. If I modify the code to not use the EDITOR_AREA by check for null,
> the maximize button will just switch to Restore-Mode without maximizing
> the PartStack.
Re: Maximizing a Part [message #666485 is a reply to message #666410] Wed, 20 April 2011 14:55 Go to previous message
Christoph Keimel is currently offline Christoph Keimel
Messages: 353
Registered: December 2010
Location: Germany
Senior Member
Hi Remy,

checked out the current MinMaxAddon from Head. Works like a charm. Thanks for the fix.

Regards,
Christoph
Previous Topic:XWT Designer on IndigoM6
Next Topic:Where is the API for accessing persisted state?
Goto Forum:
  


Current Time: Sun Sep 21 12:26:52 GMT 2014

Powered by FUDForum. Page generated in 0.02171 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software